I'm recently working with Proteus. So I created a simple schematic for a transistor to work as a switch. But when I simulate it, it doesn't work as it should. In the picture below you can see that the resistor is not receiving current at the base, however the led is lighted up as if it were. I've even tried to remove everything from the base of the transistor and even then somehow the led still lights up. So I suppose it's a problem with the software. But maybe there's a setting missconfigured that I don't know of. Have anyone had this problem or any idea on what could be a solution? Thanks.

PD. I've already tried to reinstall the software and it didn't work.

Simulation running in Proteus

  • \$\begingroup\$ Try a pull down resistor on the base to ground. \$\endgroup\$
    – Andy aka
    Jan 29, 2021 at 19:11
  • 1
    \$\begingroup\$ Thanks. I tried that but that was not the problem. I fixed it changing the "model type" of the led from "digital" to "analog". \$\endgroup\$ Jan 30, 2021 at 18:43
  • \$\begingroup\$ A good news story. \$\endgroup\$
    – Andy aka
    Jan 30, 2021 at 18:44

1 Answer 1


I fixed it. First I switched the "model type" of the Led from "digital" to "analog". Then I changed the transistor to a 2N2222. And I also fixed a design problem by adding a resistor that goes from the base to ground, to avoid any charge in the environment from turning on the transistor.

enter image description here


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.