1
\$\begingroup\$

I have built a LM555 based soft latch (toggle) with single push button according to the schematic, and while on protoboard everything seemed to work fine, the pcb version is triggering when voltage is first applied.

So when I first connect 220VAC to the pcb, the trigger latches on. After that the circuit behaves normally, every press of pushbutton toggles the relay on or off. If I disconnect 220VAC and the latch was off, it toggles on for a split second before shutting off.

There is a 9V transformer followed by a rectifier bridge and 100uF which provides around 15V when latch is off, and 12,5V when it is on. I measured the middle point between two 10k resistors and it's 7.5V (off) and 6.2V (on).

I already tried a few things:

  1. Adding a startup delay with 2,2k (or 10k) + 10uF connected to pin 4 and GND - doesn't help on its own
  2. Suspected the 100uF cap is staying charged so added a bleed resistor (1k and 2,2k) - doesn't help on its own
  3. Removing 100uF cap renders the circuit unusable (obviously the ripple from he rect bridge is too high)
  4. Increasing the C1 to 4.7uF and 10uF - doesn't help
  5. Adding a 0.01uF from pin 5 to GND - no change

All of the above doesn't fix the problem, although 1. and 2. together seem to make it appear less frequent. I want the circuit to stay off until I press the button, so what am I missing here? I'm suspecting some kind of circuit instability but can't figure it out.

Any help appreciated.

LM555 soft latch circuit

\$\endgroup\$
7
  • \$\begingroup\$ EXamine the 555 internal schematic and figure out what causes Set to output \$\endgroup\$ – Tony Stewart EE75 Feb 14 at 20:43
  • \$\begingroup\$ en.wikipedia.org/wiki/555_timer_IC#/media/File:555_esquema.png \$\endgroup\$ – Tony Stewart EE75 Feb 14 at 20:51
  • \$\begingroup\$ I read that and datasheet, output is set when pin 2 sees less than 1/3 of vcc. But how does that happen in my circuit just by applying voltage? \$\endgroup\$ – nahero Feb 14 at 21:03
  • \$\begingroup\$ Yes Set = Trigger(2)<1/3Vcc , Reset = Threshold (6) >2/3Vcc while switch (NO)= Vcc/2 to (NC) = Vout via R3C1 so the switch does both but if Vcc drops faster than Set, you get a momentary set, which should not happen with 100uF on Vcc when shut off. But will if Vcc is cutoff from 100uF but maybe logic is faulty at low Vcc \$\endgroup\$ – Tony Stewart EE75 Feb 14 at 22:37
  • \$\begingroup\$ what's the deal with the COUT label on pin 5? that's nonsense. \$\endgroup\$ – Jasen Feb 15 at 7:09
3
\$\begingroup\$

You have TRIG and THRES set to 1/2 Vcc, so the 555 could power up in either state. To ensure that it is reset on power up you should pull RST low until the supply voltage has stabilized.

Adding a startup delay with 2,2k (or 10k) + 10uF connected to pin 4 and GND - doesn't help on its own

Reset is only active when RST is below ~0.7 V (minimum 0.3 V), so with 10k and 10 uF the reset time will be much shorter than you might expect from the RC time constant. Try a much larger resistance (eg. 100k) to increase the reset time. Also put a diode across the resistor to discharge the capacitor faster on power down.

\$\endgroup\$
2
  • \$\begingroup\$ Very informative, thank you Bruce, will try that \$\endgroup\$ – nahero Feb 14 at 21:40
  • \$\begingroup\$ Increasing the resistor to 100k did not help. Tried increasing the cap as well but nothing changed. \$\endgroup\$ – nahero Feb 16 at 23:24
1
\$\begingroup\$

Add 0.1uF between pin5 and ground,

that will ensure that the 555 comes up with pins 6 and 2 above threshold causing it to re reset.

\$\endgroup\$
4
  • \$\begingroup\$ Datasheet states 0.01uf from 5 to gnd, I actually put 0.022uf but it didn't fix anything \$\endgroup\$ – nahero Feb 15 at 10:00
  • \$\begingroup\$ Actually adding a 0.47uF cap from pin5 to gnd solved the problem with powering on! Can't say I understand why. The other problem with quick toggle on when powering down still remains. \$\endgroup\$ – nahero Feb 16 at 23:26
  • \$\begingroup\$ it works because it pulls down the rerence point that's on the other end of the comparator making it less than half vcc during start-up. \$\endgroup\$ – Jasen Feb 17 at 3:29
  • \$\begingroup\$ Yes, but why 0.47 and not 0.01uf as stated in datasheet, was what I meant \$\endgroup\$ – nahero Feb 17 at 10:27
0
\$\begingroup\$

I know it's not best practice but I will answer my own question here because the solution was somewhat specific.

So the solution to the false trigger on power up was to place a 0.47uF or bigger cap (4.7uF and 10uF also work fine) between pin5 (control voltage) and GND. 0.01uF which is suggested in the datasheet doesn't work, also 0.022uF. Didn't have a suitable 0.1uF to try, maybe that works.

Also tried a delayed startup with RC on pin4 (2.2k/10uF, 10k/10uF, 10k/100uF, 100k/10uF) - nothing worked. As soon as I connect 220VAC to the board the relay latched on. So here's the solution, although the minor issue remains - when disconnecting 220VAC from the board the relay shortly latches on then off.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.