I've been trying to make a double layered PCB for a robotics project for a while now using Autodesk Fusion 360.

It's going to be the control board for the project, containing an ESP32 together with some connectors, voltage regulators and sensors.

I've had a recurring issue that seems to pop up from time to time, and I am trying to understand what is going on, and how to fix it.

From time to time, when making a prototype export for my PCB, I get a message from the manufacturing company (switching between PCBWay and JLCPCB) saying that the trace width is zero/incorrect, usually accompanied with a screenshot from what they see on their end, with all traces showing zero width, or an arbitrary maximum width. Both are obviously incorrect, but I fail to understand what I did wrong.

Things that I have tried:

  • Check for errors with CRC/ERC and solve them (only 7 accepted errors left, and those are unconnected GND pads for soldering/heat dissipation)
  • Check for weird bends/shapes in traces and clean them up
  • Used the Gerber export template provided by both JLCPCB and PCBWay (which can be found on their website)
  • Tried several custom export formats on my own, of which some worked from time to time (apparently when I left some layers out, it worked all of a sudden)
  • Check if I comply with manufacturer specifications (min hole side, trace width, trace spacing etc.)

This PCB has had several versions that I could succesfully fabricate, and were completely fine. Then in a next iteration, I would get the same error again, and both JLCPCB and PCBWay could not let me know what was wrong (which is completely valid for the low price they ask for such low volume projects).

I was hoping that someone could help me understand and/or pinpoint a bit more what I am doing wrong, so that I can improve and prevent this from happening in the future.

Some images of the PCB, and what JLCPCB returned on the last image (zero trace width)

Full PCB top side

Close-up 1

Close-up 2

Close-up 3

Close-up 4

Returned version by manufacturer with zero trace width

  • 1
    \$\begingroup\$ Um, I can't help you with your Gerber issue, but I did notice that you have your VCCUSB and 3V3 nets tied together. Are you plugging in only a device that you know has 3.3V on the USB VBUS? And you need to make sure that your decoupling caps are electrically closer to the ICs, and make your power traces wider... and since you're having trouble with AuotDesk, why not jump over to something like KiCAD. \$\endgroup\$ Commented Feb 20, 2021 at 9:17
  • 1
    \$\begingroup\$ When you examine your gerber in a third party viewer like the excellent gerbv what does the tool report as the track width on that segment? Is there garbage on the layers? Verify what the supplier thinks they are seeing in your Gerbers, you can do that textually or visually . \$\endgroup\$
    – crasic
    Commented Feb 20, 2021 at 16:54

2 Answers 2


According to you explication, there are "zero width" items in your Gerber file. So they are either 0 width or the start point is the same or too near to the end point.

You could check the Gerber files by opening them in a text editor.

You can first look for the Aperture definitions - you can consider this as the "pen" types.



The above define aperture 10 as a circle of 0.1 and aperture 12 as a rectangle with the given X and Y sizes.

You can then look for places where these are used in your file:


Indicates that the aperture 10 is used for the next lines.

If you have small apertures (0 or much smaller than 0), then you could modify the Gerber file to change the aperture size. Then load the modified Gerber file and the items that were "too small" should now be too big.

I do not have a good suggestion for items that are "too short".

Personally, to make sure that the PCBs can be produced by most PCB manufacturers, I use the online Eurocircuits PCB verification tool. It checks more stuff than my free CAD tool and it is practical in use. I avoid that the assembly house tells me that the PCB does not match the PCB's manufacturer requirements.


I've had the exact same issue for a couple of months, until I came past others with the same problem. It turned out to be a problem with me using my laptop in dutch while it should be set to english. Or at least where 1,000.0 is equal to 10*100 and not 1.000,0. Notice the location of the dot and comma?

That's where things go wrong... Very frustrating.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.