0
\$\begingroup\$

enter image description here I'm have a Arduino mega 2560 board connected with PCA9698(I/O expander) through i2c communication. Controlling if input and output were working correctly. The data pins from the PCA9698 is connected to the 24v DC motor driver(BTS7960) and also sensors(PROXIMITY sensors). While reading the sensors there are no issues, but While running the motor the PCA gets hangs and i2c gets disconnected.

New contributor
vasanth kumar is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
\$\endgroup\$
6
  • 1
    \$\begingroup\$ Probably your motor is giving some current spikes which are not sufficiently suppressed and causing the other electronics to die. If you want more details, you should post your schematic diagram here \$\endgroup\$ – Eugene Sh. Feb 23 at 20:01
  • 1
    \$\begingroup\$ Show how PCA is controlling the motor - transistor/halfbridge? \$\endgroup\$ – fifi_22 Feb 23 at 20:20
  • \$\begingroup\$ Your setup is probably demanding more current from Arduino than it can safely supply. \$\endgroup\$ – Mitu Raj Feb 23 at 20:22
  • 1
    \$\begingroup\$ There's no question asked, so at the moment there is nothing we can answer. Schematics would help though. \$\endgroup\$ – Justme Feb 23 at 21:29
  • 1
    \$\begingroup\$ We cannot help you unless you provide more information, in particular a schematic of your circuit. Photos of your setup would also be helpful. \$\endgroup\$ – Codo Feb 24 at 6:39

Your Answer

vasanth kumar is a new contributor. Be nice, and check out our Code of Conduct.

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.