1
\$\begingroup\$

I have a 9V powered multimeter (Voltcraft VC165) where the 5V LDO is broken.
When I apply 5V manually, the functions I checked so far work fine, so I'd like to repair it. The LDO is a SOT23-5 SMD part, the mark says "PAW", there is no logo visible.
Here a picture of the circuit: enter image description here

And one picture with U3 removed (I also removed and resoldered C17, and my soldering tip is... not the best ;-)

enter image description here

The circuit looks like this:
enter image description here

The switch is closed when the multimeter switch is in "OFF" position.
I checked about 100 datasheets of LDOs, but could only find two where Pin 1 is GND and Pin 2 is V_in - but for those Pin 3 is V_out, Pin 4 and 5 are not connected (JRC NJU7231 and OnSemi MC78LC00).

Is my analysis correct?
Is there a chance to find out which type was mounted here?
What replacement type would you recommend?

Thank you very much for any helpful input!

EDIT: As @Unimportant assumed, my schematic is wrong! Capacitor's GND/logic GND and battery GND are not connected.

\$\endgroup\$
4
  • 2
    \$\begingroup\$ Looks like you may have wrecked 2 of the pads, making for a much more .... interesting repair. \$\endgroup\$ Feb 28, 2021 at 18:39
  • \$\begingroup\$ @BrianDrummond Yes, these pads were obviously damaged when the part broke. It was very easy to remove. If the pads were OK it would have been much harder :-) Anyway, I'm quite confident a repair is possible using enamelled copper wire - considering Pin 4 was really "NC", what I assume, but don't really know. \$\endgroup\$
    – mic
    Feb 28, 2021 at 18:52
  • \$\begingroup\$ some creative use of glue can fix these… now the real question is why was that broken and if damage propagated downstream. In my experience when an ldo break that way all the stuff it powers get the full input voltage. Have you tried powering manually the instrument before trying the repair? \$\endgroup\$ Mar 1, 2021 at 6:54
  • \$\begingroup\$ @LorenzoMarcantonio Yes. There's an I2C EEPROM populated. I connected 5V and GND to it. When switching the multimeter on, the display was working and I could measure resistor values and DC voltages, so there's good hope that the rest is also OK. \$\endgroup\$
    – mic
    Mar 1, 2021 at 10:33

2 Answers 2

3
\$\begingroup\$

It looks to me like your circuit diagram is wrong. The 2 rightmost pads don't appear to be connected to anything (even before the damage). In that case the pinout matches the TI TLV70436DBVT , which comes in the correct package and is marked "PAW".

\$\endgroup\$
1
  • \$\begingroup\$ You are right! I don't know why I didn't measure it - obviously I simply assumed that the cap's GND is connected to battery GND. I'll order that TI device and give it a try :-) \$\endgroup\$
    – mic
    Mar 1, 2021 at 6:49
1
\$\begingroup\$

It looks like the LDO is always powered by the battery and controlled via its EN pin, so it needs low quiescent current. And yo won't find a TO-92 replacement since these don't have an ENABLE pin.

Besides that, I think it would be more practical to pick one in SO-8 package or SOT223, being larger than SOT-23 it would be easier to solder wire on it to fix the broken pads.

\$\endgroup\$
2
  • \$\begingroup\$ Ok... yes, the paclage doesn't really matter when the pads are gone anyway. But actually it's the EN pin that irritates me: All types I could find require EN (or /SHTDN) to be "High" for activating the LDO. But in all those types there's no internal pullup, so... how could it have worked in my circuit? \$\endgroup\$
    – mic
    Feb 28, 2021 at 20:06
  • \$\begingroup\$ Now that's an interesting question! By the way, are you sure it's a positive LDO and not a -5V one? \$\endgroup\$
    – bobflux
    Feb 28, 2021 at 20:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.