0
\$\begingroup\$

I am using a Microchip MCP2210 USB to SPI converter, however during operation, there is a delay between the sent bytes. Is there a way to remove this ?

\$\endgroup\$
0
\$\begingroup\$

You don't say what that delay is, but page 38 of the datasheet (https://ww1.microchip.com/downloads/en/DeviceDoc/22288A.pdf) has settable parameters at offsets 16-19 that may resolve your issues.

from data sheet page 38

A quick scan of the data sheet shows four or five High Byte/Low Byte pairs for registers with the label "Delay Between Subsequent Data Bytes". You should check them all.

\$\endgroup\$
7
  • \$\begingroup\$ I guess 17 should say "(high byte)". \$\endgroup\$ – Spehro Pefhany Mar 4 at 14:46
  • \$\begingroup\$ @SpehroPefhany yes \$\endgroup\$ – Scott Seidman Mar 4 at 14:46
  • \$\begingroup\$ Those bits are already set for no delay. The delay that I am experiencing is that of about 12ms. Thanks \$\endgroup\$ – Chris Mar 4 at 15:00
  • \$\begingroup\$ @Chris how big a packet have you defined? \$\endgroup\$ – Scott Seidman Mar 4 at 15:29
  • 1
    \$\begingroup\$ There are a few registers with the same name. Keep searching. Also, have you actually read the settings? Experience tells me that there's sometimes a difference between believing your procedure to set the registers worked, and knowing they've worked! \$\endgroup\$ – Scott Seidman Mar 4 at 16:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.