I made a schematic based on the SY8089A1AAC(Datasheet)

My schematic(I tried with and without C8): enter image description here

I soldered everything but the output is 0V(0.04V to be precise)

What is so wrong ?

It is part of a bigger PCB which does not have any other components soldered at the moment. Only the ESP32 and the DC/DC circuit. Power to the DC/DC circuit is provided with 2 little cables soldered temporary on the pcb from USB +5V and GND (measured the voltage and it is 5V..) enter image description here

I tried to "copy" the schematic of LilyGo which is based on SY8089AAAC(datasheet) enter image description here

  • 1
    \$\begingroup\$ Can you show your PCB (or whatever it is that you soldered) \$\endgroup\$
    – BeB00
    Mar 17, 2021 at 16:03
  • \$\begingroup\$ Measure voltages on different points of your soldered circuit. It could be a workmanship problem. \$\endgroup\$
    – Eugene Sh.
    Mar 17, 2021 at 16:04
  • \$\begingroup\$ @BeB00 edited the original post. \$\endgroup\$
    – Kris
    Mar 17, 2021 at 16:12
  • \$\begingroup\$ L looks too puny. What’s the DCR? <-30 mOhm? \$\endgroup\$ Mar 17, 2021 at 16:23
  • 1
    \$\begingroup\$ The Enable pin must be pulled High for the regulator to work - why are you holding it at half-supply? \$\endgroup\$ Mar 17, 2021 at 17:03

1 Answer 1


The smallest acceptable size in a 2A regulator @ 1 MHz if using 2.2uH is 4.8mm square to get 30 mOhm max with an L/R ratio of ~ 73 us and a Q<0.1 with fo of 16kHz @ 44uF and probably unstable. But yours is far too lossy and underdamped and too puny.

Remove 1 (22uF) cap also and review phase compensation design for breakpoint and phase margin. There is a problem with 5kHz phase lead compensation and an underdamped resonant frequency of 16 kHz.

This does not exclude that you may have mechanical soldering issues and the onus is on you to identify all pin voltages to verify the function of that port and all connected parts to debug in your question.

You would have been better off with 1uH 10mOhm and 10uF <1 mOhm but the datasheet only hints at that! ‘☆’ means recommended for most applications.

Rule of Thumb

Never deviate one little bit from suggested layout and components in SMPS unless you know what you are doing! (Especially but not only at >1MHz)

  • \$\begingroup\$ thanks for your reply. what makes it lossy, underdamped ,puny? the soldering isn't good? \$\endgroup\$
    – Kris
    Mar 18, 2021 at 12:14
  • \$\begingroup\$ Search DCR , L here DCR is the DC resistance of the coil which cannot store energy only lose some., but I think you have mechanical problem and a debugging problem with no voltages marked up on your schematic Have you considered a short circuit? \$\endgroup\$ Mar 18, 2021 at 12:27
  • \$\begingroup\$ you were right about the mechanical problem. i soldered an other board and it works. its either a PCB issue or some short circuit.. \$\endgroup\$
    – Kris
    Mar 20, 2021 at 13:44
  • \$\begingroup\$ Your efficiency will suffer with a puny L. Even though that schematic shows 100mOhm, the datasheet recommends 30mOhm \$\endgroup\$ Mar 20, 2021 at 14:36
  • \$\begingroup\$ are you referring to the schematic that i "copied" or to the schematic that i made? for L i choosed a "random" 2.2uH inductor(murata.com/en-global/products/… ) \$\endgroup\$
    – Kris
    Mar 20, 2021 at 14:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.