1
\$\begingroup\$

Any time I try up upload a sketch to my Arduino, I get the following error message:

enter image description here

That "1 of 10" then repeats all 10 times, and ultimately fails. I know that this board works, as I am able to upload to it and the serial monitor loop-back test work fine on another computer.

I am using an Arduino Uno, plugged in via USB, and COM1 selected in the Arduino IDE. COM1 in my Windows device manager claims to be running fine:enter image description here

I am running Windows 10, and I am using this board I am out of ideas. Can anyone help me get uploads working?

Edit: OK, now I'm getting a new device on my device manager, but Windows can't install any drivers for it:enter image description here

I went to the Arduino help page for installing drivers, and found this: https://www.arduino.cc/en/Guide/ArduinoUno#install-the-board-drivers

I found the "arduino.inf" file exactly where that page said it would be, but if I try to pick a driver manually, I get this error from device manager when selecting the "drivers" folder containing "arduino.inf": enter image description here

Edit 2: OK, had a breakthrough. Using Windows device manager, I right-clicked on my unknown USB serial device and was able to select "update drivers", "browse my computer for drivers", "let me pick from a list of available drivers on my computer", "Ports (COM & LPT)" and select the Arduino Uno.

Now COM3 shows up when I plug in the Arduino and disappears when I unplug it, and I get a different error message when uploading now: enter image description here

\$\endgroup\$
10
  • \$\begingroup\$ If you unplug the board, COM1 disappear? Have you tried different USB Cables? \$\endgroup\$
    – Damien
    Commented Mar 22, 2021 at 5:57
  • \$\begingroup\$ Using COM1 with an arduino Uno is a bit suspicious. It's probably a built-in port on the computer's motherboard (usually exposed on the COM1 header), and not a USB-connected thing. Another hint towards that is the "Location" being on a LPC Controller, aka SuperIO. Since no other serial ports are showing up, do try using a different USB cable. Also try disconnecting all IO from the Arduino if you haven't done that, just in case there is a short on the power rails. \$\endgroup\$ Commented Mar 22, 2021 at 6:08
  • \$\begingroup\$ @Damien No, COM1 does not disappear, but I don't have any other options. \$\endgroup\$ Commented Mar 22, 2021 at 6:15
  • \$\begingroup\$ @Richard the Spacecat I have tried a bunch of USB cables. The cable I am using now works and uploading works when used with the same board and another computer. All IO is disconnected. \$\endgroup\$ Commented Mar 22, 2021 at 6:16
  • 1
    \$\begingroup\$ If COM1 doesn't disappear it means it's not the port of your board, that means the COM port of your board actually never shows up. It's probably a USB cable problem or some driver problems. \$\endgroup\$
    – Damien
    Commented Mar 22, 2021 at 6:16

2 Answers 2

1
\$\begingroup\$

I did it. I used the answer from here: https://arduino.stackexchange.com/questions/55301/avrdude-ser-open-cant-set-com-state And installed the ch340 driver and I'm working now.

\$\endgroup\$
2
  • \$\begingroup\$ Maybe you should have mentioned in the question that you are not using an original Arduino Uno but a clone (no original Arduino uses a CH340). That would have led to a more focused search for a solution. Correction: I see there is a link in your question that leads to a page where the CH340 is clearly mentioned. \$\endgroup\$
    – StarCat
    Commented Mar 22, 2021 at 7:21
  • \$\begingroup\$ Also: there is a whole page on the SparkFun site dedicated to getting your particular board to work. Including links to a driver. \$\endgroup\$
    – StarCat
    Commented Mar 22, 2021 at 7:29
0
\$\begingroup\$

At the point when the program is going to be up loaded ( at half way of progressive bar) press the reset butten and instantly release it. Or you may have placed files some where else. Some updated files are not in arduino folder, but they are in mydocuments folder. They should be there where they are.Also , my front port is 16. So I think it can't be 1.

\$\endgroup\$
8
  • \$\begingroup\$ The reset thing doesn't work. I am working off a fresh install of Arduino IDE so I am not sure what you are saying about placing files somewhere else. \$\endgroup\$ Commented Mar 22, 2021 at 6:30
  • \$\begingroup\$ Becase some times we deleat files in my document folder, without knowing that arduino files are there. What i said about reset button means not the IDE. The button on the arduino board. It is there close to data cable socket. \$\endgroup\$
    – upali
    Commented Mar 22, 2021 at 6:35
  • \$\begingroup\$ Yes, I hit the physical reset button on the actual board itself. Didn't work. \$\endgroup\$ Commented Mar 22, 2021 at 6:40
  • \$\begingroup\$ Then your DTR wire in the cable may be broken in side. That wire is important. Or broken at the socket.Try changing data cable. \$\endgroup\$
    – upali
    Commented Mar 22, 2021 at 6:48
  • \$\begingroup\$ Goto file>preferences and check sketchbook location path. (at the top of pop up menu) There is the files what i said about. \$\endgroup\$
    – upali
    Commented Mar 22, 2021 at 6:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.