6
\$\begingroup\$

The MSP-EXP430G2 LaunchPad Experimenter Board User's Guide (Rev. C) in chapter 3.2 states:

The LaunchPad includes a pre-programmed MSP430G2553 device [...]

Press button P1.3 to switch the application to a temperature measurement mode. [...]

The collected temperature data is also communicated via back-channel UART through the USB emulation circuitry back to the PC. The transmitted values [...] can be displayed with any terminal application or the Temperature Sensor GUI available on the MSP430 LaunchPad wiki page http://processors.wiki.ti.com/index.php/MSP430_LaunchPad_(MSP-EXP430G2). The serial communication port on the PC must be configured with 2400 bps, one stop bit, and no flow control to display the values correctly.

I've been trying to connect to the serial communication channel from linux using PuTTY (/dev/ttyACM0, 2400Bd, 8N1), but nothing happens.

Similar results with:

stty /dev/ttyACM0 2400
screen /dev/ttyACM0

I haven't seen the LaunchPad USB serial working yet, so I'm trying to figure out whether the problem is with my Linux install or with the LaunchPad.

How can I read the data from the LaunchPad demo in Linux?

EDIT1

I am on Ubuntu 12.10 64-bit

Linux 3.5.0-21-generic #32-Ubuntu SMP Tue Dec 11 18:51:59 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux


PACKAGE NAME      INSTALLED VERSION
binutils-msp430   2.22~msp20120406-2
gcc-msp430        4.6.3~mspgcc-20120406-3
gdb-msp430        7.2a~mspgcc-20111205-1ubuntu1
msp430-libc       20120224-1
msp430mcu         20120406-2
mspdebug          0.19-1
srecord
libsrecord-dev
libgmp-dev
\$\endgroup\$
  • \$\begingroup\$ I solved the problem. While writing this question, I was on the wrong track. Data didn't display because it is binary (in contrast to what the users guide implies) and because of buffer issues. I solved the issue by writing a short perl script, which I put on my personal blog: blog.linformatronics.nl/170/linux/… \$\endgroup\$ – jippie Jan 19 '13 at 20:11
3
\$\begingroup\$

This isn't too uncommon, especially if your system is a 64 bit system. Make sure you have these installed on your system:

  • binutils-msp430
  • gcc-msp430
  • gdb-msp430
  • msp430-libc
  • msp430mcu
  • mspdebug
  • srecord
  • libsrecord-dev
  • libgmp-dev

After connecting the launchpad, it may take a bit of time (~1min or less) for the system to pick it up. What happens if you have a terminal open that is just monitoring the port like cat /dev/ttyACM0, and you connect/disconnect the unit a few times?

Are you sure you have everything else installed properly? You may need a few extra things if your system is 64 bit, and the newer kernel versions >2.4 may have a bit of a problem with some programs, but nothing that isn't easily fixed. Assuming you use some Debian distro,

sudo apt-get install subversion gcc-4.4 texinfo patch libncurses5-dev zlibc zlib1g-dev libx11-dev libusb-dev libreadline6-dev

There is a How-to: Launchpad programming with Linux article that may help.

\$\endgroup\$
  • \$\begingroup\$ Are you sure about the last three packages? \$\endgroup\$ – jippie Jan 19 '13 at 15:35
  • \$\begingroup\$ I managed to get some data using minicom. The LaunchPad spits out bytes, not ASCII data and no CR or LF. The lack of line terminators may very well explain why all the usual tools don't output anything (until the buffer is full). \$\endgroup\$ – jippie Jan 19 '13 at 15:39
  • \$\begingroup\$ @jippie The launchpad demo program doesn't send ASCII, it sends binary. \$\endgroup\$ – AndrejaKo Jan 19 '13 at 15:41
  • \$\begingroup\$ @jippie I'm not sure about the packages, it's been a while since I've played around with TI on a linux machine. I just found those from some site. \$\endgroup\$ – Garrett Fogerlie Jan 20 '13 at 5:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.