1
\$\begingroup\$

So, I recently threw out a bag of random chargers I didn't think I was using anymore. Later I found that my Dremel charger was part of these. I did however save all the connectors and just threw out the adapters, incase this would happen.

From what I can identify on images of the 7750, it is using a 5v 1650mA adapter, where the outer shell of the barrel is negative and the core is postive. Well I thought this would actually be quite nice, as I could wire it to a USB-A and just use one of my many AC-DC adapters, powerbanks, USBhubs... to charge it. (I have tried it using an old 5.2v 2.4a ipad charger, and 5v 2a oneplus charger)

So I did this and the light on the Dremel does light up red as an indication of it charging, but it never reaches max capacity (usually indicated by a green light if my memory is correct, and just turns off after a while). Once the light disappears I can turn off the power and turn it on again and the red light appears and seemingly keeps charging. After 10 minutes the Dremel is able to turn on and I can use it for a minute or so before it dying out. Leaving it for a longer period does not change the time.

I have attempted to use a cheap USB current reader, but it does not show any information, as if the current drawn is too low or something. I'm a novice in the field and would appreciate any explanation to why this is happening (:

enter image description here

\$\endgroup\$
0
1
\$\begingroup\$

Looking at the specifications of that Dremel it seems to have a battery voltage of 4.8V using NiMH technology. Which sounds like 4 cells in series to me at a nominal 1.2V.

Now nominal voltage is not charge voltage to fully charge it the battery voltage should reach closer to 1.6V per cell or 6.4V for the device. The included adapter was probably unregulated so the voltage rose significantly above the marked 5V depending on load which would work as a dumb charger for NiMH probably sacrificing some life due to poor charging characteristics.

Your nice regulated 5V from your USB compatible adapters is not going to charge that Dremel. You need something that behaves more like the original adapter.

\$\endgroup\$
7
  • \$\begingroup\$ I see. Thank you for the explanation. I will attempt to rewire it to an adapter that plugs directly into the wall. If that doesn't work could a solution be to either step up or step down the voltage to 6.4v? \$\endgroup\$ – Eyee Mar 23 at 17:55
  • \$\begingroup\$ Changing the adapter did not help. I'm hesitant to use a higher voltage as I fear frying the electronics. I tried opening the Dremel and found two large batteries labled 2v. Measuring them, while the device is pretty much out of juice, displays about 4.5v. I'm now thinking of just rewiring the power to the board, to a USB cable and just have it connected to a powerbank or plug. Would this be a possibility? \$\endgroup\$ – Eyee Mar 24 at 9:49
  • \$\begingroup\$ Unfortunate that it didn't work out, but you opened it up so any pictures of how it hooks up internally would help us tell you what could possibly work. The problem with consumer devices is that you never know what hides inside the plastic. I would be skeptical of a USB cable being able to handle the current the dremel requires I see it easily drawing 5A. \$\endgroup\$ – r_ahlskog Mar 24 at 9:55
  • \$\begingroup\$ Thank you for the help. I see. I'm not sure of the proper etiquette of adding pictures on this site. Hope imgur is alright: imgur.com/a/ieKaIFS. Searching on google it doesn't seem feasible to get a replacement charger. So at this point I don't really have much to loose. Would a possible solution then be to replace the batteries with lithium harvested from an old laptop? \$\endgroup\$ – Eyee Mar 24 at 23:50
  • \$\begingroup\$ There was way more PCB going on than guessed. It looks like it has some form of charge controller going on possibly just temperature cutoff but it is really hard to tell from the pictures. Replacing the cells would get you new and interesting problems including how to charge lithium safely. \$\endgroup\$ – r_ahlskog Mar 25 at 9:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.