0
\$\begingroup\$

I'm relatively new to KiCad, but I've had some success in the past generating boards and having them manufactured - though admittedly it's been a while.

I'm using 5.1.9 on MacOS 10.14, and I've generated my schematic (just a simple 3x3 switch matrix, plus an extra switch) using just two different components:

  • 11x switches using an imported symbol/footprint (from SnapEDA) of an Omron B3F-4055 pushbutton switch
  • 1x 1x8 2.54mm pitch connector (for which there wasn't a footprint, but I assigned one) Schematic

When I initially generated the netlist from Eeschema, Pcbnew opened to an empty window. I don't mean a blank board, I mean a window with all the editor chrome and options, but no board to edit.

Blank PCB

If I randomly click around in the empty window, I can seemingly select parts that are invisible to me, so I think it's there, but I can't see it for some reason. (Note the different details on the bottom of the window)

Note the different details on the bottom

Searching around, I found a similar post here that said to use the Update PCB From Schematic tool. I used the tool, learned that the connector (J1 on the schematic) didn't have a footprint, and assigned a similar footprint that will work for my situation using the Assign Footprints tool in Eeschema.

Now Update PCB From Schematic passes just fine - no warnings or anything - but I still get an empty PCB file. So I'm kind of at a loss here.

Hopefully that's enough info and it's something stupid I'm doing. I attached a few images to show what I made and what I see.

Thanks in advance!

\$\endgroup\$
4
  • 2
    \$\begingroup\$ Have you tried changing the toolset? (In preferences) The default (Modern accelerated) one uses hardware acceleration, so perhaps that is glitching? \$\endgroup\$ – Arcatus Mar 25 at 6:36
  • 1
    \$\begingroup\$ I think there's an option to switch between the legacy view and the OpenGL view, right? Maybe try that. Since you can select components, it sounds like the actual board is okay, it's just invisible \$\endgroup\$ – user253751 Mar 25 at 13:10
  • \$\begingroup\$ Did you import the netlist in PCB view? \$\endgroup\$ – Mattman944 Mar 25 at 13:20
  • \$\begingroup\$ It seems quite a big installation or compatibility problem… doing a file new from pcbnew at least give you an empty sheet? \$\endgroup\$ – Lorenzo Marcantonio Mar 25 at 15:34
3
\$\begingroup\$

@Arcatus and @user253751 - that was it. I was in Modern Toolset (Fallback), and when I switched to either Legacy or Accelerated, that fixed it.

For those that find this - you'll find those options in pcbnew under the Preferences menu. I'm on a 2015 MacBook Pro 13" running 10.14 in case that matters, too.

Thanks!

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.