7
\$\begingroup\$

I have an 800W ATX power supply given to me by a friend because it doesn't work any more. It's quite a beast and would set me back a considerable amount new, so I'd like to see if I can fix it.

Well, here's the story. It has standby power at 5.15V. The power indicator on the back lights up (on the mains switch - it's an LED not a neon apparently, because when you turn off the unit it fades slowly, making me think it's not directly connected to the mains.) Anyway, when you turn it on (by grounding the PS_ON pin) it makes a faint clicking sound but does nothing else. With my scope I have found three short pulses of ~11.8V on the 12V rail for about 500 ms to 1.5 seconds before the supply goes dead, which makes me think some kind of protection system is being activated, as the power supply does work - it is producing the required output.

If it doesn't work it is going in the trash, so no loss there.

\$\endgroup\$
  • \$\begingroup\$ Do you have a load (working PC) attached to it? Many ATX supplies require a minimum current draw to operate. \$\endgroup\$ – Kevin Vermeer Oct 24 '10 at 23:32
  • \$\begingroup\$ I was told it was dead already, but good idea, I have a spare mobo + CDrom, would this be enough load? \$\endgroup\$ – Thomas O Oct 24 '10 at 23:35
  • \$\begingroup\$ Tested it with a computer which works (mobo, processor, hdd, cd+dvd, fdd) with a 250W PSU and it still clicks, probably not drawing more than 50W but could this be insufficient still? \$\endgroup\$ – Thomas O Oct 24 '10 at 23:44
  • \$\begingroup\$ Yes, that should be plenty. If that's insufficient, then there's something else wrong with the PSU (but you knew that). \$\endgroup\$ – Kevin Vermeer Oct 25 '10 at 1:59
  • \$\begingroup\$ I have a 400W FSP with same symptoms. Please comment when you have fixed yours telling how :) \$\endgroup\$ – csadam Oct 25 '10 at 11:54
13
\$\begingroup\$

Bad capacitors. It's always bad capacitors (and it's never Lupus). They've dried out and become resistive. In the process they sometimes make life ugly for power transistors and diodes.

If you're not safe with some mains voltage (there may be some in the hot side of the supply) please don't open the box.

Look for swollen electrolytic capacitors (metal cans). Replace with reputable parts with same values (no consumer components supplier will sell parts as nasty as a cheap manufacturer can buy wholesale).

Check diodes and transistors on output side for blowage.

Main high voltage mains side capacitor might be dried out. Shows up as overload in feedback paths and shutdown. Replace it. Must be same voltage rating!

Go see the sci.electronics.repair FAQ.

\$\endgroup\$
  • 1
    \$\begingroup\$ Good point on the caps. But I would think they would only cause excessive ripple and not a complete failure of the supply. I am experienced enough to repair this, but I'm still uncertain if the caps could cause such a problem. \$\endgroup\$ – Thomas O Oct 25 '10 at 0:04
  • 4
    \$\begingroup\$ Thomas, if the main capacitor only has 1% of it's capacity, the feedback loop will try to track the "ripple", overload and will shut down. In the last 5 years, it's all been either capacitors, or capacitors and the diodes & transistors around them. Try it. \$\endgroup\$ – Tim Williscroft Oct 25 '10 at 0:39
  • 1
    \$\begingroup\$ Capacitors make up a large part of what causes failures in many parts of a CPU. \$\endgroup\$ – Kortuk Oct 25 '10 at 3:04
  • 1
    \$\begingroup\$ @Thomas: While the capacitors are some of the most failure prone components, when they gave out they may have taken several other parts with them. The safe bet to save a buck would be to get a new one. If you don't really care about making it work but want an interesting experience, go for it. \$\endgroup\$ – Nick T Oct 25 '10 at 3:46
  • \$\begingroup\$ He said he wanted to sell it. \$\endgroup\$ – Kortuk Oct 25 '10 at 14:41
3
\$\begingroup\$

I'm going to go with Tim's answer. The caps are my first suspect. I once checked out a DVD player whose 5V line would pulse, much like your 12V line. Turned out to be a bad cap in the rectifier. I almost missed it, until I started touching the tops of all the caps with my finger (this is a good time to remind you to avoid getting yourself a Darwin award!). It was then immediately apparent which cap was bulging.

\$\endgroup\$
  • 3
    \$\begingroup\$ I think this may make a better comment. \$\endgroup\$ – Kortuk Oct 25 '10 at 23:58
  • \$\begingroup\$ When you say rectifier, do you mean the input filter, or the output filters? It's an active PFC supply and uses a massive 470µF 400V capacitor. \$\endgroup\$ – Thomas O Oct 30 '10 at 1:57
  • \$\begingroup\$ When I said rectifier, I meant the power supply board as a whole, which was a separate board from the main logic. I think for the DVD player I fixed, it was a cap on the DC side, but in general just touch the tops of all of them and feel for a bulge. I think designers have respect for AC and use higher-voltage caps, but think "oh this is just 5V so I can use a 6V rated cap..." \$\endgroup\$ – ajs410 Nov 1 '10 at 18:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.