1
\$\begingroup\$

I am trying to understand transistors by experimenting. Having a pushbutton drive a single transistor to switch on an LED works, but trying to drive the second transistor from the first has me confused.

Even though the second transistor turns on and drives its own LED, the LED of the first transistor doesn't switch "on" any more.

Can someone explain the theory behind the first LED not turning on?

This question is similar to my previous question but I specifically want to know why this circuit behaves this way.

my circuit

\$\endgroup\$
13
  • 1
    \$\begingroup\$ Theoretically the Left Led should glow from basic circuit concept point of view, the problem is the series 220 resistor from battery. It will decrease the voltage at upper side of 264 resistor to level the Left Led has too little current. Btw, it is not a good aproach drive Led thru base of (right) transistor. \$\endgroup\$
    – user208862
    Apr 4, 2021 at 0:19
  • 1
    \$\begingroup\$ Both LEDs should go on when the switch is pressed. If it fails to behave that way maybe the circuit is not as you have presented. It's a strange circuit, I don't know why you would do that. \$\endgroup\$ Apr 4, 2021 at 0:42
  • \$\begingroup\$ A more conventional solution would be to use a PNP transistor for the second LED and add it's base as a load to the first unless you want to use the first LED as an indicator of the base current. \$\endgroup\$
    – K H
    Apr 4, 2021 at 1:25
  • \$\begingroup\$ Andy, what kind of LEDs are you using? I'm just curious. \$\endgroup\$
    – jonk
    Apr 4, 2021 at 1:40
  • 1
    \$\begingroup\$ the battery is installed backward \$\endgroup\$
    – jsotola
    Apr 4, 2021 at 1:45

1 Answer 1

1
\$\begingroup\$

The Circuit-Lab Simulator says that both LEDs should turn on, although D2 will be brighter than D1 as there's almost 3 times the current flowing though it.
Check your construction and take some measurements to debug what's going wrong.

schematic

simulate this circuit – Schematic created using CircuitLab

enter image description here

\$\endgroup\$
2
  • \$\begingroup\$ R4 is 220 ohms in the OPs diagram. \$\endgroup\$
    – Mattman944
    Apr 4, 2021 at 3:12
  • \$\begingroup\$ @Mattman944 - fixed, although it made little difference to the outcome. \$\endgroup\$
    – brhans
    Apr 4, 2021 at 13:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.