1
\$\begingroup\$

I have an Arduino Nano controlling a BTS7960 that is 10 meters away.

I have one 24V power supply.

Both the Arduino and the BTS7960 get 5V through a an LM2596 step down converter.

The BTS7960 "Enable" pins are hooked up to 5V output of the step down converter.

schematic

My problem is that this setup burnt the BTS7960 Before replacing it, I want to identify what made it burn.

I suspecting that either the RPWM and LPWM became both HIGH (from parasites + long wire ) and burnt the driver so I should add pull down resistors, or there is something wrong with this configuration and using buck converters with common GND is what caused problems.

When I turn on the power supply the motor rotates for few seconds even though the Arduino didn't give orders to turn the motor on yet.

\$\endgroup\$
30
  • 1
    \$\begingroup\$ Could well be a ground loop. Is the 24V supply coming from the Arduino side, or the motor side (yes, it matters). \$\endgroup\$ – TimWescott Apr 13 at 14:56
  • 1
    \$\begingroup\$ @tlfong01 Two PWM for the two Direction clockwise and anticlockwise and speed, i'm afraid that my setup and long wires can generate voltages in both PWM pins at same time this will surely burn the driver \$\endgroup\$ – Snaier Apr 13 at 20:38
  • 1
    \$\begingroup\$ @TimWescott the 24V start from the Arduino side then goes to the Driver and the motor. \$\endgroup\$ – Snaier Apr 13 at 20:39
  • 1
    \$\begingroup\$ I would consider placing transceivers or line drivers between the arduino and the BTS7960. 10 m is a fairly long distance for the fairly weak arduino outputs. \$\endgroup\$ – Math Keeps Me Busy Apr 13 at 21:47
  • 1
    \$\begingroup\$ How fast are you driving the PWM? It makes a difference as to whether what you're trying is ever going to be feasible without an Arduino right at the motor. \$\endgroup\$ – TimWescott Apr 13 at 23:56
1
\$\begingroup\$

You probably have a ground loop, and it's causing false signalling from the Arduino to the motor driver.

Basically, if you look at your diagram, you need to mentally substitute a string of resistors and inductors for all of the wires. The longer the wire is, the larger the resistance and inductance -- and ten meters is entirely too long for a single-ended logic-level signal.

Communication over that distance, in the presence of a noisy power connection* should either be done with the very careful application of something like RS-232, or -- far better -- with differential signalling (like RS-422) or by carrying the signal ground on a separate wire from the Arduino to the motor driver, and then using opto-isolators at the motor driver.

With your current setup, when the motor is on, and especially when you're driving a PWM signal to it, voltage will appear across your ground wire -- but the signals you're using to the driver board are referenced to the Arduino's ground. If the motor ground drops enough, the signals from the Arduino can both appear to be "on", even if they're not. Moreover, if the driver isn't protected, then the signals can go outside of the voltage range the chip can stand, and fry it on the input side.

Using differential signalling or opto-isolators running off of a separate reference ground from the Arduino will fix that. Using an Arduino on the left side for whatever user interaction you want, with a serial line (that itself uses RS-422) to the Arduino on the right side to drive the motor, will fix that.

You could also just generate 5V at the motor, and power the Arduino with a separate ground wire that's well-isolated from the one driving the motor. As long as you don't have any other ground connections, that may work -- but, 10 meters is a long way for what you're attempting.

Or you could place the motor driver right next to the Arduino, and just run your 10m wires out to the motor. That may actually be the easiest way to accomplish something that's electrically sound.

Having a circuit at the motor driver that won't let you simultaneously drive both half-bridges would be a good thing, too.

* Anything powering a motor is noisy.

\$\endgroup\$
4
  • 1
    \$\begingroup\$ Thank you that is so helpful. if i use Two separate PSU one for the motor one for Arduino and the Driver, will it work without needing to use differential signalling and another Arduino at the driver side ? \$\endgroup\$ – Snaier Apr 13 at 21:45
  • 1
    \$\begingroup\$ Doesn't work that way. The signalling looks like it's on two wires, but it's between those two wires and ground. Change the ground voltage, and you change what the motor driver sees. \$\endgroup\$ – TimWescott Apr 13 at 23:54
  • \$\begingroup\$ I had the motor driver right next to the Arduino in my first setup, the issue was the power loss in the long wire, when i attempt to run at 30% speed the driver output is somewhere around 7V but at the end in the motor side the voltage drops to 2 V and i loose all the torque \$\endgroup\$ – Snaier Apr 14 at 9:01
  • \$\begingroup\$ Arguably, the correct solution is to not use any hobbyist stuff at all but properly designed PCBs. Ideally with CAN which is more modern and rugged than legacy RS-422. \$\endgroup\$ – Lundin Apr 16 at 13:59
-3
\$\begingroup\$

Question

The OP's BTS7960 DC motor driver module was fried. What can be the possible causes?


Answer

Short Answer

  1. One possible cause for frying the motor is that the OP uses a wiring and control scheme which might burn for a wrong combination of signals. (See Appendix C for more details. One solution is to use the classic L298N/BTN7961B wiring/control scheme, which I found working OK, so far so good.

  2. One workaround for sending signals over 10 metres long distance is to use current loop for not so frequency controls, for example, change motor direction lower than 10Hz.

  3. For sending PWM signals over long distance, one solution is to use UART control PWM/sig gen, as described in Appendix A (a)'s Q&A.

  4. If the OP prefers the risky connection scheme, it is important to avoid disconnecting motor when power is on, because back EMF spike might go back through ground wire to interrupt the Arduino and cause unexpected control signals to the motor driver and fries it.

  5. For the problem: "When I turn on the power supply the motor rotate for few seconds even though the Arduino didn't give orders to turn the motor on yet, ..."

    The problem might disappear if Connection/Control scheme #2 is used AND INH pin is pull down to ground.


/ to continue,


Long Answer

Contents

Part A - Possible causes of burning BTS7960 list

Part B - Troubleshoot BTS7960 tips list

References

Appendices

Part A - Possible failure analysis/causes short list

There are many possible causes. Below is a short list.


(1) Why is my PWM efficiency about 50%? Asked 5 days ago Active yesterday Viewed 330 times

1.1 My wiring setup.

1.2 My testing setup.

1.3 My input signals.


(2) Anything wrong with connecting L298Ns in parallel? Asked 17 days ago Active 12 days ago Viewed 154 times

2.1. Part 2 - How to use L298N input signals, IN1, IN2, and INH


(3) How to control DC motor speed by motor driver with PWM input? Asked 9 months ago Active 3 days ago Viewed 913 times

3.1 References: Part C - PWM Full H-bridge Motor Driver

3.2 Appendix A - L298N input signal routing diagram

3.3 Appenidx E - BTN7971B block diagram and input signals

3.4 Appendix L - Calibration of BTN7971B PWM/Duty Cycle (1kHz, 50% Duty cycle) performance


Part B - Troubleshooting Tips List

(1) KISS (Keep It Simple Stupid), Divide and Conquer testing suggestion

1.1 Following my locked answer (Part 1, s1.3) I would suggest to test the BTN7971B dual half bridge modules in two parts, and test only one of the parts, as shown in the figure below:


half bridge test


Notes

  1. The right part, half H-bridge #2 in grey, is disconnected (actually only rewiring is to disconnect IN2, input to half H-bridge #2 (IS, INH is common/shared between both half-Bridges). So only the left part, half H-bridge #1, is wired up for uni-direction testing on (a) PWM vs motor speed/efficiency, (b) current measurement using the IS pin only (ie, no clumsy, not so accurate, clamp meter is needed to be used as described in Part 1 (1)).

  2. The OP's BTS7960 dual half H-bridge module might have only one of the two half bridges fried. So lucky him might use this wiring diagram to check out if one of the half H-bridge is still alive, and try my suggested tip below to do some investigation research/feasibility studies, as a preparation for (firing) his coming, second new module. :)


/ to continue, ...


References

(1) BTS7960 High Current 43A H-Bridge Motor Driver User Guide - Hanson Tech

(2) Easy Setup Motor Driver BTN7960/ BTS7960 with Arduino - FireBitLab

(3) Double BTS7960B DC 43A Stepper Motor Driver H-Bridge PWM Driving Board Module - Thai McuCity

/ to continue, ...


Appendices

Appendix A - BTS7960 DC Motor Driver Module Schematic - Hanson Tech

bts7960 schematic


Appendix B - BTS7960 DC Motor Driver Module Control Signals - Hanson Tech

bts7960 control signal


Appendix C - Why was the OP's BTS7960 Module Fried?

1. I found the Hanson Tech user guide a bit weird: its control signal names do not correspond to its schematic.

2. Its control procedure is also weird: There are two direction mode enables, one for forward mode, another for backward mode.

My immediate question is this:

what will happen if both forward mode and backward mode are enabled at the same time? Won't the module melt down?

3. So I googled to know more. I had good luck: I found a YT which has a truth table that confirms my worries. See the picture below for what I found! :)

Easy Setup Motor Driver BTN7960/ BTS7960 with Arduino - FireBitLab


burn burn burn


burn truth table


Notes

  1. This is a very stupid mistake I never expected to see! I need to confirm the OP if what I saw is true!

Appendix D - Two different schemes of control signal/procedure as described by Thai McuCity

(3) Double BTS7960B DC 43A Stepper Motor Driver H-Bridge PWM Driving Board Module - Thai McuCity

two schemes


Notes

1. The main difference between the two schemes is the following:

(a) Method 1 does not short/combine En_A and En_B, and module would burn if both En_A and En_B are High.

(b) Method 2 shorts En_A and En_B together, the combined En_C is used as a High/Low or PWM signal to Enable/Disable or change speed of the whole module/motor. There is danger of burning the module by wrong combination of En_A and En_B signal.


Appendix E - L298N Connection/Control Signal Scheme Test Results

Using L298N signal and control everything goes well.

Youtube video of BTS7960 Test


PWM test

/ to continue, ...


\$\endgroup\$
2
  • 1
    \$\begingroup\$ There is no need for a table of contents on a well written answer. See Tim's answer for a well written, to the point answer. Again, SE is not a blog site. \$\endgroup\$ – Transistor Apr 14 at 17:53
  • 1
    \$\begingroup\$ @tlfong01: Snaier already knows that setting LPWM and RPWM to high at the same time will cause the driver to burn up. From the question:"the RPWM and LPWM became both HIGH (from parasites + long wire ) and burnt the driver so i should add pull down resistors." The question is how did those two signals manage to go high at the same time when the code doesn't do that. \$\endgroup\$ – JRE Apr 15 at 7:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.