1
\$\begingroup\$

Yesterday I wanted to see, how much power my EFM8LB1 uses, when it has just this firmware with bootloader disabled:

.org 0
ljmp 1$
1$:
orl (REG01CN), #8
orl (PCON0), #2

Today I found, that I cannot access it via C2 anymore. I tried keeping it in reset when powering on and then sending C2 commands... without success...

How can I fix it without dumping the MCU and soldering a new one?

How does that EFM8LB1 decide if the reset means "now we do C2" or "now you run the reset ljmp"?

\$\endgroup\$
2
  • 1
    \$\begingroup\$ check the datasheet \$\endgroup\$
    – jsotola
    Apr 23, 2021 at 21:35
  • \$\begingroup\$ @jsotola i did. but: the datasheet is not very clear about my questions. after the reset it seems like the MCU starts to turn everything off, before i can send the "halt core" byte. but i dont understand why, because i only wait less than 5usec after reset and the code execution starts allegedly after appr. 50usec. \$\endgroup\$
    – RRIDDICC
    Apr 24, 2021 at 5:52

1 Answer 1

2
\$\begingroup\$

seems like it is possible to "brick" a EFM8LB1 and EFM8UB2... https://www.silabs.com/community/mcu/8-bit/forum.topic.html/efm8ub2_efm8lb1_noc2afterstop-PSub

not even a power-on-reset delay of >3msec helped in my case: https://skybluetrades.net/unbricking-efm8ub3-thunderboard/

-arne

\$\endgroup\$
2
  • \$\begingroup\$ Have you tried the suggestions in the last messages of: silabs.com/community/mcu/8-bit/knowledge-base.entry.html/2015/… ? \$\endgroup\$
    – devnull
    Apr 25, 2021 at 12:06
  • \$\begingroup\$ @vangelo sure... i even used a pnp BJT and observed the voltage rise (it took appr. 800usec) and then i wrote the magic bytes and then i tried to erase the chip, but even that failed, although it needed less than 1500usec. It seems like it does not initialize the SFRs immediately after RST/C2CK goes high. \$\endgroup\$
    – RRIDDICC
    Apr 25, 2021 at 12:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.