I am working on a six layer PCB, the layers are Top layer, layer 1...layer4, Bottom layer. I am trying to create a polygon pour on any internal layers (for example layer 1). However when I try to pour it, I am not able to do so, Altium simply shows the outline of the polygon but does not fill it. Anyone know what I am missing? As a side note, All my polygon pours on Top and Bottom layers work perfectly fine.

I am using Pour Over all same net objects as the fill mode.


In Altium, I am unable to pour polygons on any internal layers (they do not fill), while polygons on the top and bottom layers fill just fine. This is what I get when I try to pour on any internal layer (layer isolation is enabled) enter image description here

As you can see only the border is created.

Here are the settings I am using for reference as well. enter image description here

If anyone knows the relevant setting to allow me to fill the polygon I would greatly appreciate it.

  • \$\begingroup\$ Have you assigned a net name to the pour? \$\endgroup\$
    – qrk
    Commented May 11, 2021 at 20:21
  • \$\begingroup\$ Yes It has been assigned, does not change anything however. \$\endgroup\$
    – TeachMe
    Commented May 12, 2021 at 3:18

2 Answers 2


Have a look in the settings window for the polygon:

Remove Islands Less Than in Area

Your polygon is almost certainly smaller than 2500 sq mil, so it isn't being poured. You can either reduce this number or uncheck the box. Repour and it should be filled.


First thing:

With the layer selected double click on polygon pour, click on the graphical tab and then make sure fill mode is on solid.

Second thing:

Press L then change the view mode to standard 2D (or this can be done if you have the toolbar enabled)

  • \$\begingroup\$ The fill mode is Solid(copper region) the option Pour over same net polygons is selected, and the correct net is assigned. Standard 2D view mode is selected. Still does not fill properly. Could it be anything else? \$\endgroup\$
    – TeachMe
    Commented May 14, 2021 at 1:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.