0
\$\begingroup\$

In Eagle (v9.6.2), the routes fill the holes of my pads. hence when I want to print it, the pads are all black, no drill holes. What am I missing?

I know this is similar to Eagle Ground Pour Fills Drill Hole, but the answer did not work for me...

I'm expecting all the pads to show a white hole like the second column:

enter image description here enter image description here

\$\endgroup\$

3 Answers 3

1
\$\begingroup\$

Try using 'CAM Processor' instead of Print:

  • Choose 'PS' as output device and give an output file
  • uncheck 'Fill pads' in 'Style'
  • make sure only layers Top, Vias and Pads are selected (or Bottom, Vias and Pads for the other side)
  • click 'Process Job' and ignore the warning about layers not matching the layer setup.

Then you can print or convert the PS file to PDF.

I'm using an earlier version of Eagle (7.6.0), so things may be a bit different.

\$\endgroup\$
3
  • \$\begingroup\$ i have the cam processor dialog open, where do I "Choose 'PS' as output device and give an output file". I got gerber, top copper selected, with the different layers, but i do not see PS nor the fill pads style ibb.co/t3dv898 \$\endgroup\$ May 24, 2021 at 18:03
  • \$\begingroup\$ @will.mendil Looks like this dialog has changed a lot between Eagle versions. I don't know what would work for v9.6.2, but maybe have a look in the "Legacy" and "Drawings" sections. \$\endgroup\$
    – DamienD
    May 24, 2021 at 18:09
  • \$\begingroup\$ unfortunately not the legacy does not help. But what your are telling me is that this was an option before, so it should be doable in this version also \$\endgroup\$ May 24, 2021 at 18:16
1
\$\begingroup\$

I feel foolish, but I just needed to print it anyway, the pdf and printout does indeed show the hole...

enter image description here

\$\endgroup\$
0
\$\begingroup\$

At bit late to answer, but the solution I have found for [holes filled by traces when exporting as image] is to INCLUDE the top layer.

I am only putting tracks etc on the bottom layer for single sided boards, but to get all the holes to show I MUST select the top layer visibility. As my top layer has tracks representing jumpers etc I have to delete these before exporting.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.