0
\$\begingroup\$

I'm running 110 WS2812B LEDs with an Wemos D1 mini clone (AZDelivery) and the first LED flickers and won't even turn off but rather show red or green. I changed the data line cable several times, tried different resistor values (220,370,520), changed the first LED with new ones even from different sellers and changed the Wemos Pin from D5 to D0.

In the beginning it worked well for around 4-5h before the flickering started when the brightness of the LEDs changed. After that no ever what I did it won't stop even though all the other LEDs run perfectly. Even when disconnecting the single LED from the rest it still flickers. The measured voltage from my 8A Meanwell powersupply was 5.18V max. My code is using the FastLED library and dimms the LEDs based on the surrounding light and eventually turns them off. The data line cable is around 20-30cm long and soldered on the Wemos Pin.

Any ideas what's the cause? It has to do with the data line because otherwise all other LEDs would be affected too if my powersupply would be the cause right?

Edit: also tried a logic level shifter for the data line, no effect at all Edit 2: redid the complete electronic now with a NodeMCU and a way shorter data line with a 330 ohm resistor, problem persists, now I'm completely clueless, tried everything and resoldered every connection

\$\endgroup\$
4
  • \$\begingroup\$ Show all details of cable. You have signal integrity issues from mismatched impedance, unbalanced lines and SMPS noise. Use shielded STP wire and use about 150 ~220 ohms \$\endgroup\$ Jun 9, 2021 at 12:03
  • \$\begingroup\$ @MarcusMüller I used multiple of the same clone before for different ws2812b projects and never had any problem, but it's probably a good idea to try a different board \$\endgroup\$
    – Janik
    Jun 9, 2021 at 12:12
  • 1
    \$\begingroup\$ @Janik If MCU has 3.3V outputs, the LED still needs 5V inputs. Which kind of level shifter you used, there's wrong ways doing it, and there's right ways of doing it? \$\endgroup\$
    – Justme
    Jun 9, 2021 at 16:21
  • \$\begingroup\$ Have you considered that the first LED in the string might be defective? You could try to bypass it. \$\endgroup\$
    – StarCat
    Jul 15, 2021 at 6:07

1 Answer 1

1
\$\begingroup\$

Same issue, but I solved it. Install Arduino version 1.8.13.

\$\endgroup\$
1
  • \$\begingroup\$ You can expand this answer. Are you saying that it's likely op is experiencing a known software bug, likely with whatever library he is using? \$\endgroup\$
    – Passerby
    Dec 12, 2021 at 5:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.