0
\$\begingroup\$

Situation: STM32F469 Discovery board with DSI 800x480 Screen, broken native BSP drivers (Display-related part). I tried to create a project in STM32CubeIDE, set all the settings, initialized as default for the discovery. Added BSP files. Doesn't work. Spent 2 months editing BSP drivers, but only got it to half-working state.

Solution I found this morning: if I create the project FIRST in Touch GFX Designer, I can choose example program for my discovery board. Then I press "Run Target", and it uploads a whole working GUI program to the discovery board. It even generates all the main files, sets up FreeRTOS, generates CubeMX file with the CORRECT settings (which are different from default settings if I make new STM32F469-disco project, no wonder it doesn't work).

So, I have full code of a working program with all necessary drivers/files/initializations included, all hardware setup, and it WORKS when uploaded via TouchGFX Designer. BUT!

I can't upload (flash) it in STM32CubeIDE! Only via TouchGFX Designer "Run Target". Where I can't edit code, obviously.

In STM32CubeIDE, I go to "File"->"Open Projects from File System", go to the project folder generated by TouchGFX Designer, it has all mains, all SDRAM setups and everything-everything, fully working thing, and the folder structure is just like any other natively created STM32CubeIDE project. Except that when I right click any file in this project (which btw has a symbol of folder for whatever reason), "Run As" is grayed out for no obvious reason, even though it has mx ioc file, main.c file, all libraries, drivers, linkers and stuff.

Question is: how can I force STM32CubeIDE to upload this project from STM32CubeIDE and not from TouchGFX Designer? (100% identical files, 0 changes, TouchGFX can upload it, CubeIDE can't)

I tried to google this question, but it's hard to word it right, and I couldn't find anything of value.

P.S. ST Community forum is malfunctioning now, login doesn't work there, but someone should know something, I hope.

\$\endgroup\$
0
\$\begingroup\$

So, it sounds like you have everything set up properly. I don't know what version of the STM IDE you are using (I am using 1.7.0). However, the project file will have a generic name (I am using a STM32F769I-DISCO board so my generic name is STM32F796I_DISCO). Go into the .project file found in the STM32CubeIDE folder, open this in your editor and in the name field found under projectDescription change the name to the application name. After doing this, simply open the project in the IDE as you did above and all should be good.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.