0
\$\begingroup\$

I started working on a U-blox LEON-G100 gprs modem connected to the PC terminal through UART. Whatever character I enter into the terminal gets echoed back except "AT". When I enter "AT", the modem hangs up. Then I have to reset the modem to make it respond. So, I cant even execute a single AT command. As it echoes back every character I enter until "AT" sequence, I think there is no the electric connections and the UART port settings must be correct too. What would be wrong here? I had experience with other GPRS modems, but this is the first time I am encountering this bizarre trouble.

\$\endgroup\$
  • \$\begingroup\$ Do you have something like auto-bauding enabled which does a poor job? \$\endgroup\$ – Tom L. Feb 4 '13 at 20:26
  • \$\begingroup\$ Its a new board based on the U-Blox modem which bought very recently. I just hooked it to a buspirate which acts as a USB to uart converter. The baudrate at the PC terminal is set at 115200 which will work perfectly according to its datasheet. \$\endgroup\$ – 0xakhil Feb 4 '13 at 20:28
  • \$\begingroup\$ If I'm not completely wrong, that module has auto-bauding enabled. Try to send "at" a few times. After a while it should figure out the baud-rate and respond. \$\endgroup\$ – Tom L. Feb 4 '13 at 20:38
  • \$\begingroup\$ My mistake.. I forgot to put it in null modem state. It had hardware flow control enabled by default. Wasted a lot of time. \$\endgroup\$ – 0xakhil Feb 4 '13 at 20:38
  • \$\begingroup\$ Hey, I figured it out. It has hardware flow control enabled by default. Shorted the CTS and RTS lines and its working fine now. Thanks for the reply. \$\endgroup\$ – 0xakhil Feb 4 '13 at 20:40
2
\$\begingroup\$

I figured it out. The modem had hardware flow control enabled by default. So I had to put it into null modem state. Its just a matter of shorting CTS and RTS lines each other. Now its working perfectly fine.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.