I am using Raspberry PI 4 Model B (4GB) with an official capacitive 7" display. I am powering the device using an external AC-DC (220VAC - 12V) power supply. I converter 12V to 5V using a buck converter to power the Raspberry Pi and LCD.

I have two power supply MeanWell GS60A12-P1 (End of life product) and GST60A12-P1J (new product). Everything is fine using the end of life power supply GS60A12-P1, but using the new power supply the touch screen is almost unresponsive. If I touch the backplate of the LCD or any power pin, the screen works. If I ground the backplate of the LCD, everything works (but grounding is impossible using this AC-DC adapter). Both power supplies have almost the same specification.

I am guessing, that there is a problem with common-mode noise. I tried to place a common mode choke on the 12V power line and common mode filter - Did not help.

I tried to disconnect the earth connection for the AC plug. Helped a little bit, but the screen still was unusable.

What could cause this problem?

P.S. I tried to measure the noise of both power supplies, both look similar, except GST60A12-P1J have 890Hz (100mV) noise beside 480kHz switching noise (50mV). I don't know from where the 890Hz noise is coming.


1 Answer 1


It's most likely an EMI problem, as capacitive touch screen are very sensitive to it.

Make sure you have connected the ground wire to the power supply (VAC; N; GND). If it doesn't help, try to add a common mode choke and a ferrite at the 12V cables.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.