3
\$\begingroup\$

I'm doing my firs PCB design, and I've choose to use KiCad.

The problem that I'm encountering is that when I look at my board in 3D view, the components' designators does not appear to be on the silkscreen by default (or maybe the 3D view doesn't display them ?)

Is there an easy way to add components designator on silkscreen without adding them manually one by one ?

Here is my PCB layout:

enter image description here

And here it is in the 3D view:

enter image description here

PS: The "Input" designator is added manually by me.

\$\endgroup\$
1
\$\begingroup\$

KiCad treats the designators differently than the normal silkscreen (not sure why), but as long as they are visible (right click, select "visible" - it looks like yours are set to "invisible") then they will be on the final gerber.
Any text set to invisible can be set not to show by selecting the "render" tab (top right) and deselecting "hidden text".

See the greyed out designator in the below clip compared to the others for an example of the difference:

KicadPCB

You can confirm this by plotting the top silk layer and checking in GerbView. Notice that the greyed out designator C8 isn't plotted on the gerber.

KicadGerber

P.S - The KiCad-users mailing list is an excellent place for enquiries, features suggestions, bug reports, etc.

\$\endgroup\$
  • \$\begingroup\$ I might be wrong, but no, when I right click and edit the label, "Visible" is checked. I'll double check that tonight, and also try to plot the gerber file to see if there is a difference to the 3D view \$\endgroup\$ – Nicu Surdu Feb 6 '13 at 10:13
  • \$\begingroup\$ OK! I see there is an option when you plot the Gerber file to choose what to show on the silkscreen. Thank you! \$\endgroup\$ – Nicu Surdu Feb 6 '13 at 20:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.