1
\$\begingroup\$

I want to pair Bluetooth with computer. I want to sent some data and plot them over Bluetooth. But following two not giving any response on serial connection.

I need to connect Bluetooth module which HM-10 115200 or ZS-040[HC-05] for displaying serial data, so I ONLY use MSP for UART connection for pairing commands AT and AT+INIT\r\n commands.

I can't get any answer from it! But, It should. I can't and don't understand why?

Here some what I did for connection

[20619.441479] usb 3-3.2: Manufacturer: Texas Instruments
[20619.441482] usb 3-3.2: SerialNumber: ***************
[20619.445638] cdc_acm 3-3.2:1.0: ttyACM1: USB ACM device
[20619.446257] cdc_acm 3-3.2:1.2: ttyACM2: USB ACM device
[20982.378808] usb 3-2: USB disconnect, device number 23
[20991.088759] usb 3-2: new full-speed USB device number 26 using xhci_hcd
[20991.252134] usb 3-2: New USB de...nd, idVendor=0**1, idProduct=f**2, bcdDevice= 1.05
ls -l /dev/ttyACM*
crw-rw-rw- 1 root uucp 166, 0 Jun 25 18:58 /dev/ttyACM0

Then I gave some permissions

sudo chmod a+rw /dev/ttyS4
sudo chmod a+rw /dev/ttyACM1
sudo chmod a+rw /dev/ttyACM0
sudo chmod a+rw /dev/ttyS4
ls -l /dev/tty*
crw--w---- 1 root tty    4,  9 Jun 24 12:07 /dev/tty9
crw-rw-rw- 1 root uucp 166,  0 Jun 24 18:29 /dev/ttyACM0
crw-rw---- 1 root uucp   4, 95 Jun 24 12:07 /dev/ttyS31
crw-rw-rw- 1 root uucp   4, 68 Jun 24 18:40 /dev/ttyS4
crw-rw---- 1 root uucp   4, 69 Jun 24 12:07 /dev/ttyS5

I tried with screen command and over energia serial console I connect but can't receive any response

Connection

MSPBoard side BT Module
VCC 3V VCC
GND GND
TX RX
RX TX

I tried two of Bluetooth module but can't get any response on 9600 or 115200 via energia serial and

sudo screen /dev/ttyS4 9600 or sudo screen /dev/ttyACM0 9600 commands terminal freezing sometimes barely gives ?

SIMPLE SCHEMATIC

  1. Ripped all Msp430G2's all jumper then connected just RX & TX.

  2. Supplied Bluetooth module VCC->3.3V[HC-05 5V], GND->GND pins connected different stable psu then RX and TX connected reversely to each other.(just tried two model for ensuring)

   MSP430G2 Lauchpad  |             
   debugger           |                    Bluetoth module
    _____________________________________________________________________
   |                  |                   ______________________        |      
   |                 o|o Test           o|  EN                  |       |          
   |                 o|o RESET      3.3Vo|  VCC                 |       |         
   |           - - - o|o RX         GND o|  GND    HM-10        |       |          
   |           |  |- o|o TX    -------- o|  TXD     &           |       |           
   |           |  |  o|o VCC   |    ----o|  RXD    ZS-040       |       |    
   |           |  |---|--------|----|   o|  STATE               |       |      
   |           |______|________|          -----------------------       |                
   |                  |                                                 |
   |                  |                                                 |
   |                  |                                                 |
   |---               |                                                 |
   |usb|              |                                                 |
   |---               |                                                 |
   ----------------------------------------------------------------------
   Usb to computer(ofcourse)                   
\$\endgroup\$
6
  • \$\begingroup\$ It sounds like there are some level conversion and inversions that may not be there in the hardware. Post a schematic, not a frizzy thing showing your system and include links to technical information on the hardware devices. \$\endgroup\$
    – Gil
    Jun 25, 2021 at 20:37
  • \$\begingroup\$ @Gil I did. I hope looks better now \$\endgroup\$
    – maxemilian
    Jun 27, 2021 at 10:30
  • 1
    \$\begingroup\$ Start by connecting RX to TX on the USB/serial board and see if what you type is echoed back, and at what speed(s) this works (if it does), using which device, and so on. Once you have confirmation this works, you can connect the BT module. You may want to check the speed that module supports (and if that matches the MSP’s speed), the power and logic levels (voltages) and possibly if RX/TX actually need to be crossed (some devices have RX/TX labelled from the MCU perspective, not their own, so RX-RX and TX-TX. \$\endgroup\$
    – jcaron
    Jun 27, 2021 at 12:13
  • \$\begingroup\$ Unless I am reading your question wrong one is 5V and the other is 3.3V, you need a level translator. using resistor dividers is at best extremely shaky. \$\endgroup\$
    – Gil
    Jun 27, 2021 at 19:16
  • \$\begingroup\$ @jcaron you're right, this msp430 board device I think doesn't support Linux. But MspEXP430F5529LP good echoing on /dev/ttyACM1 port. This board looks good echoing every baud rate between 300-2000000 baud this problem's first part solved. \$\endgroup\$
    – maxemilian
    Jun 28, 2021 at 5:25

1 Answer 1

0
\$\begingroup\$

There is wrong point using this board on Linux and Mac clearly described here

NOTE: eZ430-tools are not supported on USB3.0 ports. eZ430 tools are supported on Windows operating systems only—Linux and OS X are not supported.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.