I have been using Kicad for about a month for my project. While finishing up the 2 layer design, I wanted to print out a negative plot on a butter paper with the top and bottom layer printed side by side on it, making it easier to get a photoresist quickly.

I tried the plot/pdf option and print option from the file menue. In the plot-pdf option, the output PDFs were on different scales so the printout was not accurate as all footprints changed because of no scaling. In the print option, there is no negative plot option, so I used two softwares to try and invert the content inside the edge-cut. I used gimp and inkscape. In both the softwares, I faced the scaling issues as well, while exporting the inverted layers.

The not so good final way I resorted to, was to scale the printout at the Ctrl+P stage, by taking the print of wrongly scaled top and bottom from plot/pdf option and print(+ gimp/inkscape) option, measure how much it was off by, and then decide the scale, and input it at Ctrl+P.

Is there anything that I am missing?

  • \$\begingroup\$ Please mention the KiCAD version you are using in your question. \$\endgroup\$ Aug 31, 2021 at 4:36

1 Answer 1


Make sure the pages sizes are the same across all the places. I recommend using the print option, where you have more control of the page setup.

Make sure the page size in File>Page Setting is set to A4 or any other.

In Print option, check if the page size is set to same A4 or any other in the 'Page Setup' button.

Also make sure the size is same in your printer setting as in other settings above.

If that still doesn't work, and you have already figured out the scale number from using gimp/Inkscape. You can directly input that number in the print option under 'Scale' to get the 1:1 directly from KiCAD.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.