2
\$\begingroup\$

Hi I believe this problem must be classical and well known but I cannot find a place where it is specifically discussed: I have build a simple non inverting 2X amplifier following exactly the classical and simple circuit as discussed for example in the answer to this question: Amplify 0 - 3.3V DAC signal to 0 - 10V as well as in many textbooks. I use a LF351DT opamp with Vs+=12V and Vs- to GND. and 2 10k resistor to get a 2X amplification. I feed it with a variable 0-5V DC and measure output. This is all there is in the circuit.

The circuit works as it should when the input is large enough (>~1.5V) that means Vout=2X Vin but for small value the opamp output is constant ~10V. I tried different chips ( same model) and this is reproducible. I cannot find a place where this effect is discussed. Does anybody have an idea on what's going on and how to deal with it? Thanks

\$\endgroup\$
4
\$\begingroup\$

Does anybody have an idea on what's going on and how to deal with it? Thanks

It's called signal inversion (also phase reversal) and happens when the input goes beyond the upper or lower limit specified in the data sheet. Basically, the output polarity flips and things become fairly meaningless: -

enter image description here

enter image description here

2nd picture from here.

My advice is to add a small negative supply rail to the op-amp negative supply power pin or, use a rail-to-rail device.

\$\endgroup\$
1
  • 1
    \$\begingroup\$ Thanks to Andy and devnull its exactely what I was missing. \$\endgroup\$
    – jf_vt
    Aug 30 at 11:30
2
\$\begingroup\$

According to the datasheet this is not a rail-to-rail device:

enter image description here

The datasheet does not provide detailed specs for the voltage rails you are using, but you can see that the output can't reach the positive rail, and this is worse the larger the output current.

You should also not expect correct behavior with 0V inputs.

\$\endgroup\$
2
  • \$\begingroup\$ Ok but I dont understand how this relate to the fact that Vout is 10V when Vin is 0 \$\endgroup\$
    – jf_vt
    Aug 30 at 11:23
  • \$\begingroup\$ I've added some information on how to extrapolate the datasheet information to your case. \$\endgroup\$
    – devnull
    Aug 30 at 11:28
2
\$\begingroup\$

You need an op-amp that can function with the input at the lower supply rail, or you need a negative rail. Once you go outside the input limits (which you are doing with an input so close to the negative rail) anything can happen.

Since you have 12V available you don't need a Rail-to-rail op-amp, a single-supply type will likely do, or one with input common mode range that includes the negative rail and rail-to-rail output.

For example, an LM358 has an input range that includes the negative rail and goes up to about 10V with a 12V supply (see Fig 1). It can supply typically almost 20mA while dropping less than 2V (so 10V out) but I would not depend on more than 5-7mA, so a minimum 1.8K load or so.

\$\endgroup\$
1
  • \$\begingroup\$ Thanks for the practical explanation JF \$\endgroup\$
    – jf_vt
    Aug 30 at 12:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.