I loaded up the example sketch for the itead Motomama on my Arduino Mega ADK and I see the green led's in the middle of the board slowly going on and off as expected from the sketch. The problem is, as soon as I connect a motor, well, nothing happens and the LED's don't do anything either (on the side that I connect the motor . . . the other side works fine). I use the same motors on the official Arduino Motor Shield and it works fine (using a 12V input).

When I check the voltages comming off the screw terminals I see it going from about -6 volts to 6 volts . . . much like when I check the volts on any PWM pins.

I tried connecting the power directly to the Vin/Ground pins on the shield and got the same result.

And, I connected a BTBee to the XBee socket and added a bit of sample code to send text from the Arduino through BT back to my phone (using a test app) and that part works fine too.

There are a couple of jumpers on the other side of the screw terminals and I can't help but wonder what they do but haven't seen anything in the (sparse) docs about them.

Any ideas?


1 Answer 1


There are jumpers next to the screw terminals. I can't find anything in the docs about what they do. But on a whim (and since there were no replies here) I switched the jumpers around and IT WORKS. The test program works. I'm a bit nervous about the fact that I input 12 volts and the motor is only getting about 6 volts (see an earlier question) . . . but this chip is WAY BIGGER and even has a heatsync and I feel like it's probably the culprit. There are docs about the L298N chip in the itead website I need to check out.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.