I'm currently building a prototype device at work, that involves a QFN-64 0.5mm pitch IC (a PIC microcontroller) soldered onto a SchmartBoard|ez prototyping board. The SchmartBoard instructions call for the use of flux, which is not something I normally need to use, so I grabbed a Kester flux pen off the shelf and proceeded with soldering the chip, with no apparent problems. My initial firmware development was quite successful, but at that point I was only using a few of the chip's I/O pins. I've since reached the point where I need all of the I/O pins to work - and am finding that several of them are stuck low, despite having a weak pull-up resistor enabled. I'm measuring voltages in the 2-3V range on these pins (in a circuit that shouldn't have anything other than 0V and 5V present), and measuring resistances as low as 500Ω between adjacent I/O pins. I won't bore you with the full list of possible explanations I went through, but it eventually occurred to me to take a closer look at that flux pen - it's Kester 2331-ZX, not the no-clean flux that I had used in the past, but the type that requires cleaning immediately after soldering. Oops! And this soldering had been done about a week ago... (Also, it turns out that the flux pen had been sitting on the shelf for 2 years past its expiration date. I have no idea if that makes things any worse than they would otherwise be.)

I've tried a heavy-duty flux remover spray from MG Chemicals, and a couple of other PCB cleaning sprays. I've tried 91% isopropyl alcohol. I've tried rinsing the board under hot water, followed immediately by drying with a heat gun. None of this has achieved more than a slight improvement (that 500Ω pair of adjacent pins is now up to 600Ω, for example).

Is there anything else I can try to salvage this board? I have little confidence that I'd be able to desolder the chip while leaving the board in good enough state to solder a new one on - and I've got a lot of other components and wiring on that board, that I really don't want to have to redo. this is as good of a picture as I can take

  • \$\begingroup\$ Could try submerging it in lacquer thinner for an extended period (overnight) but this may yield little results and create lots of waste. Best to remove, clean, and re-solder (use solder paste with flux in it), or make a new board with solder paste. Time to practice hot-air skills. \$\endgroup\$
    – rdtsc
    Commented Sep 29, 2021 at 18:28
  • \$\begingroup\$ Flux issues aside, the joints look rather questionable at a glance. Looks like "bridges" in some places, unless it's all flux residue. The much easier solder joints elsewhere on the board (to the upper right) are botched cold joints, so I'd question the state of the whole board. \$\endgroup\$
    – Lundin
    Commented Oct 4, 2021 at 11:59

2 Answers 2


I have real doubts that this is your problem.

For leakage caused by flux residue I've used a toothbrush and solvent of some kind such as IPA or lacquer thinner as well as soapy water.

But the leakage was in the 100's of M\$\Omega\$ or G\$\Omega\$ (low enough to be a problem in very sensitive precision analog circuitry, not digital circuits), and not a mere few hundred ohms. So at least 5 orders of magnitude higher. I doubt even plumbing solder acid flux would be quite that bad (but it would be bad).


Kester 2331-ZX is water soluble acid-based flux which needs to be washed off immediately after soldering. If not washed off, it will turn gold black rendering the pad unsolderable. The flux is hygroscopic (absorbs moisture) which can affect high impedance circuits. However, I think your problem isn't flux related. If the device has a paddle (central thermal pad) you may have a solder bridge(s) from pins to the paddle. Perhaps removing the part and reattaching would be in order.

  • \$\begingroup\$ I have not personally encountered solder bridges that were anything other than a dead short. Are you really saying that this is a possible explanation for a few hundred to a few thousand ohms between pins? (My chip does have a thermal pad, but all of the problem pins are showing multiple megohms resistance to that pad.) \$\endgroup\$ Commented Sep 29, 2021 at 18:18
  • \$\begingroup\$ High resistance could be due to the flux and moisture. I've had circuits with 300k ohm impedances get messed up due to water soluble flux that was improperly cleaned. If you can, remove the part, clean the evil flux and use a non-water soluble flux. Some of our production boards, we don't allow water soluble flux due to entrapment of the flux (flux left behind in cavities) which rots the wire over time. \$\endgroup\$
    – qrk
    Commented Sep 29, 2021 at 19:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.