1
\$\begingroup\$

I want to use FT230XS IC to translate UART to USB, as a cheaper alternative to FT232RL, which I use for years now.

The MCU I use is an Atmega328p-au (so the same configuration as an arduino), and I also have an USB isolator between the PC and the rest of the PCB, like this:

schematic

simulate this circuit – Schematic created using CircuitLab

What works: Every time I re-plug the USB or reset the com port the MCU resets, and I can transmit and receive data from the MCU.

What does not work: The issue is, when I try to burn code using the bootloader (either by using Arduino IDE or Microchip Studio), it says "out of sync". BUT, I can see the RTS line resetting as normal via the oscilloscope when I initiate a bootloader burn. So it actually resets, but not fast/slow enough?

Here is the "out of sync" error using AVRdude:

out of sync

Or arduino:

arduino error

I can see that the MCU is responding, so it actually tries, but its really out of sync. I also see on the oscilloscope, the RTS pin resets the MCU as it should be:

rts reset

I tried Inverting the pins: RTS,CTS,DTR,DSR,DCD,RI (one at the time) but no luck:

invert pins

Also a picture of the PCB while probing it with the oscilloscope:

PCB

So I suspect that there is something wrong either with the connection between FT230XS and MCU (Like I should use the CTS pin), or a sync error that can be caused by longer wire from PC to the PCB, (but I used a short wire and didn't help), or the USB Isolator might delaying the signal(?).

This is the first time I use the FT230XS. Has anyone use it before and managed to upload a bootloader to any MCU (preferrably an atmega)? If yes, what was the connection between the FT230XS an the MCU?

\$\endgroup\$
5
  • \$\begingroup\$ what kinds of oscilloscope is that? \$\endgroup\$
    – Pete W
    Sep 30, 2021 at 17:19
  • \$\begingroup\$ also why capacitive coupling of RTS? \$\endgroup\$
    – Pete W
    Sep 30, 2021 at 17:23
  • \$\begingroup\$ @PeteW I always used capacitive coupling with DTR pin when using FT232, so I though it would make sense, and it works. (except from the bootloader thing of course). Do you think this is the mistake? \$\endgroup\$ Oct 1, 2021 at 7:06
  • 1
    \$\begingroup\$ @PeteW Looks like an "old" LeCroy oscilloscope :) \$\endgroup\$ Oct 7, 2021 at 9:53
  • 1
    \$\begingroup\$ @PeteW LeCroy 9314AL Quad channel 400MHz (Last calibrated 26-July-2000 hehe) \$\endgroup\$ Oct 7, 2021 at 11:23

1 Answer 1

0
\$\begingroup\$

It Eventually fixed by itself the next day (in the middle of the next day). I am pretty sure there was something dirty on the PCB (flux leftovers probably).

And it works just fine -for a week now- after that day.

I actually used a IC oven to solder that PCB, using liquid solder that was expired. Maybe this caused some issues, since I do not use liquid solder to solder these components, I just tried it on that PCB.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.