Voltage regulator

Hi, Im using TPS53353DQPR to generate 3V3 from 12V0. Even when the enable pin is low , there is around 2.5V on the output. I removed FB5, still there is voltage on output when enable is low.I tried isolating it from all the possible leakage points but Im unable to bring it down . Is there any possible solutions that i can implement? Thanks

  • \$\begingroup\$ It looks like you did not manage to remove all the possible leakage points. Show the schematics to see the rest of the circuit and tell more what you tried to do to isolate the leakage. \$\endgroup\$
    – Justme
    Oct 25, 2021 at 15:41
  • \$\begingroup\$ If you removed FB6 then where would the output voltage be leaking from? R117? seems unlikely but you could test that hypothesis by measuring the VFB voltage. \$\endgroup\$
    – user253751
    Oct 25, 2021 at 15:45
  • \$\begingroup\$ @user253751 The leakage could come via any circuit that is powered by the 3.3V supply but not shown on this schematic page. It could even come via R123 for all what we know. Also, there is no FB6 shown on the schematics. It might be a typo or not, as there is FB5 in the schematics. \$\endgroup\$
    – Justme
    Oct 25, 2021 at 16:45
  • \$\begingroup\$ @Justme can i know how the leakage can come from R123 that is on the Power good pin? \$\endgroup\$
    – soul z
    Oct 26, 2021 at 11:38

1 Answer 1


"There is 2.5V on the output". You're measuring it with a multimeter with 10MOhm+ input impedance. It doesn't take much to drive 2.5V into megaohms. Try loading that output down with say 1kOhm resistor and see what you measure then. My hunch is that it'll be <1mV.

But make sure you're telling us the full picture: the circuits that use VCC_PROC_PCH_3V3 cannot be connected to any other power source either, and they can't have their inputs driven by external circuitry either.

Remember that you can make some CPUs run on nothing but parasitic power coming on the digital logic lines. That's what happened to the very first ARM processor prototype (look on YouTube for some entertaining material about that). It appeared to consume a zero current: due to a mistake in the test setup, it was not fed any power, but instead was running on the current sourced from the bus pins driven by other ICs that were powered on, such as memories :)

  • \$\begingroup\$ Hey, I cant post the whole schematic for NDA and the design is huge. I wanted to know if is there any way possible to remove this voltage by any method? Thanks \$\endgroup\$
    – soul z
    Oct 26, 2021 at 9:15
  • \$\begingroup\$ And i also tried Pulling it down. i used 100Ohm resistor. 1.8V was found. \$\endgroup\$
    – soul z
    Oct 26, 2021 at 13:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.