3
\$\begingroup\$

While trying to access the CR50 chip in my Dell Latitude 7410 Chromebook, I tried making my own Suzy-Q cable because no online store seems to have some in stock.

I bought some USB breakout boards, and tried to build this: https://chromium.googlesource.com/chromiumos/third_party/hdctools/+/master/docs/ccd.md#making-your-own-suzyq with

  • GND pins soldered together
  • VCC pins soldered together
  • Proper resistors (22k and 56k) soldered to VCC pins
  • A8 (SBU1) soldered to USB D+
  • B8 (SBU1) soldered to USB D-

When connected to the Chromebook, this should trigger USB-C Debug Accessory Mode and expose serial interfaces.

USB-C breakout board 1 USB type A breakout board USB-C breakout board 1

My problem: After plugging everything to the Chromebook and another Linux computer, I am not having any sign of any serial interface. I tried lsusb but nothing appears and dmesg does not show anything when I plug or unplug my device (and I have nothing when I try to find ls /dev/ttyUSB*).

Of course, I also tried the cable in the other orientation since it is supposed to work only in one orientation. My soldering skills are quite bad but everything is soldered properly (I double checked, even with a microscope).

Did someone manage to make this kind of cable? What should I look for?

It seems that user DannyS (Making own Chromebook debug cable (SuzyQable)) had a similar issue but after trying multiple male-to-male USB-C cables (even high-grade Thunderbolt 3 cables), I am still having the same behaviour.

Also, if this is not an hardware issue, does someone know if I have to enable something on my Linux computer?

\$\endgroup\$
7
  • 1
    \$\begingroup\$ These are 100% very bad solder joints. Might want to watch a few beginner tutorials about soldering - wetting in particular. Solder isn't "hot glue in metal form", but there to make both a mechanical and electrical connection on both metal surfaces. \$\endgroup\$
    – Lundin
    Nov 9, 2021 at 11:08
  • \$\begingroup\$ Did you make any continuity check for all of the contacts? \$\endgroup\$ Nov 9, 2021 at 11:42
  • \$\begingroup\$ How long is the cable between the breakout boards? Also it doesn't look like the right kind of cable. I'd recommend using a section cut from a proper USB cable instead. \$\endgroup\$ Nov 9, 2021 at 11:46
  • 1
    \$\begingroup\$ The solder joints aren't great (excess solder, probably insufficient pre-tinning of the wires) but they don't look bad enough to cause immediate failure. Maybe a side view of the USB2 board to double check for a fillet on D+ and D-. \$\endgroup\$ Nov 9, 2021 at 11:53
  • \$\begingroup\$ I know my solder joints aren't great, I am still learning and I'll do better next time, thank you for your advices! However, @RohatKılıç, I did continuity checks for all of my joints and contacts, and everything is fine. \$\endgroup\$
    – geckoflume
    Nov 9, 2021 at 13:25

1 Answer 1

3
\$\begingroup\$

You missed an important step in the construction of your debug cable. The instructions say to use a male (plug) breakout board, while you used a female (receptacle) breakout board.

Inside a USB C cable, only 1 CC (A5/B5) is connected to the other side, while a "debugging cable" need both pins connected to a resistor.

You cannot cut your cable, as there is only 1 wire for the CC pins.

You need to use a male (plug) USB C breakout board and wire it up following the instructions

With the way you wired it up now, you basically emulated a normal USB A to C cable in 1 direction, and a 1.5A USB A to C cable in the other direction, not a debugging cable.

\$\endgroup\$
3
  • 1
    \$\begingroup\$ Very good point, now I remember that aspect of the debug accessory mode! \$\endgroup\$ Nov 10, 2021 at 13:37
  • \$\begingroup\$ That must be it! I thought Thunderbolt 3 USB-C cables had everything connected, but this was a wrong assumption. I will try with a male USB-C breakout board, thank you very much! \$\endgroup\$
    – geckoflume
    Nov 10, 2021 at 16:09
  • 1
    \$\begingroup\$ @geckoflume only 1 CC line is connected in the cable, the other one is connected to a chip in either plug that says the cable is USB 4.0 and says the maximum charging speed. Some special cables use it to power optical encoders for high speed transfer via glass fibers instead of coppee \$\endgroup\$
    – Ferrybig
    Nov 10, 2021 at 16:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.