1
\$\begingroup\$

I have a multi-channel design in Altium Designer which was done specifically to speed up component placement within each generated room on the PCB.

After adding some components to the schematic, updating the PCB, and arranging new components in one of the rooms, when I try to use the Copy Room Format function with the "Copy Component Placement" option, nothing happens and I get a dialog indicating that "0 components out of N rooms were updated."

Copy Room Formats Dialog

I've restarted Altium, checked component channel offsets, ensured the room definitions (rules) are enabled, and tried selecting only one component at a time, etc. What else can I try to get these component placements copied across rooms?

I am using Altium Designer 21.8.1.

\$\endgroup\$

2 Answers 2

2
\$\begingroup\$

After much trial and error, I inspected component classes (Design > Classes) and noticed that the new components were not members of the room classes.

I checked the project options (Project > Project Options) to ensure that class generation was enabled for the needed rooms and for component classes.

I decided on a whim to try importing the changes from the schematic (from the PCB editor), even though I'd already done so by choosing to update the PCB from the schematic editor. Surprisingly, the detected differences included components which were not members of the room classes. After accepting the ECO and applying it, the Copy Room Format function worked!

In sum:

  1. Check if all components in the rooms are members of the appropriate room class.
  2. Try importing changes from the PCB editor after updating the PCB from the SCH editor.
\$\endgroup\$
0
\$\begingroup\$

You also need to disable the "Copy selected objects only" when you are copying. I think this is a usability problem in Altium. This option should not be there! You can review it 100 times and don't understand where the problem is...

room copy dialog

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.