1
\$\begingroup\$

I want to conect the ez430-rf2500 development tool with PIC16f877 throught uart, do I have to use a max232 chip in order to be able to communicate between those two MCUs or it can be done without it.

\$\endgroup\$
2
  • 1
    \$\begingroup\$ It might be worth adding what voltage both systems are running at. \$\endgroup\$
    – PeterJ
    Mar 2, 2013 at 1:35
  • 1
    \$\begingroup\$ I guess, @Kostas meant PIC 16 F877, because PIC 18 F877 model doesn't exist. \$\endgroup\$ Mar 2, 2013 at 1:58

1 Answer 1

1
\$\begingroup\$

You can connect the PIC's UART to the MSP430's UART directly, if the power supply voltages are the same. So, it is possible get away without an RS-232 driver such as MAX232. Of course, you would need to connect the grounds together.

As a side note, MAX232 generates the true RS-232 voltage levels. These are higher than the voltage levels, which the UART outputs. The benefit of higher voltage levels is that the true RS-232 is more immune to interference.

What if the power supply voltages aren't the same?

PIC16F877 can use supply voltages between +2V and +5.5V. MSP430F2274 on the ez430 can use supply voltages between +1.8V to +3.6V. Suppose that the MSP430 runs off +3.3v, and the PIC runs off +5V. MSP430F2274 doesn't have inputs that are 5V-tolerant.

The supply voltage ranges overlap. May be, lowering the supply of the PIC16F877 to +3.3V is an option. You may need to lower the oscillator frequency. Check that other components, which share the power supply rail with the PIC can operate off +3.3V.

If your design doesn't allow you to lower the PIC's supply voltage from +5V to +3.3V, there are level shifters (or level translator) ICs. See this post for details.

\$\endgroup\$
2
  • \$\begingroup\$ Nick thank you for your detailed answer and yes I meant 16f877 sorry for that ;) If I use a voltage divider at the PICs TX and RX pins to get the +3.3V whould it fix that problem? \$\endgroup\$
    – Kostas
    Mar 2, 2013 at 4:03
  • \$\begingroup\$ @Kostas Voltage divider would work. Your baud rate is probably not too high. \$\endgroup\$ Mar 2, 2013 at 4:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.