6
\$\begingroup\$

I followed a tutorial on Sparkfun to put together a 5V power supply. But for some reason I'm only reading 4V coming out of the regulator. I know it's not the regulator because this is the second one I've tried. I checked the data sheet to make sure it's connected right and yet the problem still persists. I'm pretty sure I'm giving it enough power because it outputs 4V with a 9V wall wart input as well as around 15V from two 9V batteries in series. Eventually I gave up and decided to move on, even though 4V is below the minimum rating of the ATmega328p (4.5V,) and now I'm facing problems trying to program the chip, which I assume is because of the chip not getting enough voltage.

Does anyone know why the regulator isn't regulating properly?

The schematic for the power supply is:

enter image description here

from here

\$\endgroup\$
  • \$\begingroup\$ 1. Did you check the pin out is correct? 1 - Input, 2 - Ground, 3 - Output? 2. How much voltage are you providing on the input? You should be providing at least 7V, maybe 7.5V to be sure. \$\endgroup\$ – miceuz Mar 2 '13 at 1:58
  • \$\begingroup\$ Have you measured the input voltage to the regulator? What is it? Have you tried another 7805 in case the one you're using is damaged? \$\endgroup\$ – Gustavo Litovsky Mar 2 '13 at 8:09
  • \$\begingroup\$ @GustavoLitovsky I am currently inputting 9v and only getting 4v output, and I tried two regulators, both giving 4v \$\endgroup\$ – Michael Mar 2 '13 at 8:16
  • \$\begingroup\$ How much current are you trying to source? Common 9V batteries can not source much. \$\endgroup\$ – Gunnish Mar 2 '13 at 8:47
  • 2
    \$\begingroup\$ Alright. So what actually happened was that I was using an old and faulty multimeter. So I went and got a new one from radioshack. Now with my shiny new meter I'm reading 5v. I gotta say what a relief to finally figure this one out. \$\endgroup\$ – Michael Mar 3 '13 at 4:05
10
\$\begingroup\$

If you are doing everything correctly then the chances of it working correctly are extremely high (99.999%)

SO it is very likely that you are doing something other than you say or imply. Follow the following to see if we can find out what the problem is:

Are you using C1 and C2?
You MUST to start.

Are they close to the regulator?
Must be close to start.

What is your load?

What is Vout with no load?
5V?

Have you put a new battery in your voltmeter ?
("Low battery" in meters is a too common cause of apparent voltage errors.)

What are you using for the PTC resistor?
If it is too high a resistance it will cause problems.

The PTC is wholly unnecessary to start and reasonably unnecessary in any case.
If you are using one, short it out.
Were you using one?

If the circuit is not your EXACT circuit please modify it to show EXACTLY what you are doing.

Report ...

| improve this answer | |
\$\endgroup\$
4
\$\begingroup\$

These IC's don't put out exactly 5V. But the error shouldn't be more than a few percent.

That you tried two and they didn't work does not strictly rule out that both may have been defective, but it reduces the statistical likelihood.

Pay attention to the datasheet. Does the input side of the regulator have enough voltage? These devices require a certain dropout, meaning a certain voltage drop from the input voltage to the regulated output voltage. The dropout voltage must be maintained at all times (instantaneously), not just on average, which is one reason why there have to be filter capacitors on the input side.

The first circuit, "basic regulator configuration", shown in that tutorial page, therefore, is not correct. You must build the circuit with all the capacitors. Check all your connections. If a capacitor isn't connected properly, it's effectively not there. (Is this on a breadboard socket, or soldered circuit?)

Make sure you haven't connected the regulator in reverse.

Lastly: is your multimeter working properly, and are you using it correctly?

You should take a step back from your project and question everything you're doing. The circuit schematic you're working from is sound. These 7805 chips work and are a "no brainer" to use. There are millions of them out there in all kinds of devices.


Bingo: It was the multimeter, evidently.

| improve this answer | |
\$\endgroup\$
  • \$\begingroup\$ He said that he had tried two regulators. See my comment to miceuz re voltage in. \$\endgroup\$ – Russell McMahon Mar 3 '13 at 3:16
  • \$\begingroup\$ @RusselMcMahon That's new information since yesterday. \$\endgroup\$ – Kaz Mar 3 '13 at 3:29
  • \$\begingroup\$ Kaz - 'No biggie' - interest only: I checked the edit log (mainly because I remembered otherwise and it's good to know any time that my memory leads me astray) - and the original shown there mentions both two ICs tried and 9V wall wart. I don't know if edit log shows purely owner edits but I assume so. I originally added the circuit diagram which he had linked as he did not have enough rep to add it. \$\endgroup\$ – Russell McMahon Mar 3 '13 at 3:51
1
\$\begingroup\$

I guess you are drawing more current. But if you are getting 4v with no load, then check if you have grounded correctly, check with caps of 0.1uF.

| improve this answer | |
\$\endgroup\$
1
\$\begingroup\$

You said that you have also provided the 15v to the circuit and yet it is providing the same 4 volts? If that's the case, then the most chances are the problem in your regulator. You said

    you tried the second regulator and faces the same problem 

if it is then try regulator of some other manufacture. And one more try you can give, by increasing c1 from 100uf to 470uf, or a lit higher. Your circuit is correct. improper ground cannot be problem(as some other says) in my opinion. because in case of improper ground the regulator mostly outputs very low output or mostly 0volt. High current drainage can be problem for low voltage output. For that you should check following things

    ->. How much current your circuit is taking? 

If this power supply circuit giving 4volt with out any load then the high chances be the problem in c2 or some other shortage near power LED.

         Try to check any shortage in circuit 

     ->. If you connected this power supply with some other circuit that takes supply from this cuircuit

Then try to find out the total current of the load. If the Load is not of high current then there are chances that you may some how make some where shortage in the soldering. You can also check the heat of regulator if it is heating too much then shortage is must if it is normal

    then the most cases are in problem of regulator or C2 capacitor.  
| improve this answer | |
\$\endgroup\$
0
\$\begingroup\$

I have used many of these and each worked fine, try the following:

  1. Be sure capacitors are close to it. I usually attach them to its legs directly.

  2. Take out components one by one i.e. switch, PTC, diode. (connect voltmeter to its input and ground terminals)

  3. If still a problem take away any load and connect voltmeter. Try to keep one dial analogue meter in addition to your expensive digital one.

| improve this answer | |
\$\endgroup\$
  • 1
    \$\begingroup\$ I've improved the format a little but it would be worth clarifying point 2 a little more, it's a bit unclear where you mean the voltmeter should be connected and what for. \$\endgroup\$ – PeterJ Oct 7 '14 at 11:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.