2
\$\begingroup\$

Issue: I have a board which uses a MCP2510 CAN controller and ATMega 32U4. During testing I found I couldn't communicate with the CAN controller. After some probing I found the CAN controller clock wasn't oscillating at all. The clock circuits for the 32U4 and the CAN controller share the same components: 7V-16.000MAHE-T crystal and a pair of 22pF capacitors. The 32U4 has an RS resistor bridging XI and XO with a value of 1M, the CAN controller has no RS resistor by default which was an oversight on my part.

Things I've tried:

  • I verified the 32U4 clock was oscillating at 16MHz with a clean wave form.
  • I verified the designed load capacitance: 22pf^2/(2*22pF) = 11pF. Load capacitance of crystal is 12pF, I've allowed 1pF for trace and component capacitance.
  • Adding RS to the MCP2510 clock circuit. I've tried 1M and 100K. This would cause the crystal to start oscillating but it was at 150kHZ and quite unstable.
  • Tried another 16MHz crystal I had in stock. This is a unmarked part but is likely for a Arduino, packaged in a can with leads. It would also oscillate at 150KHz with any RS.
  • Tested on two different assemblies with the same results.

I'm not sure what else to try to get the oscillator working. Any ideas would be appreciated.

Edit:

32U4 Clock Circuit

32U4 Clock Circuit

MCP2510 Clock Circuit

enter image description here

MCP2510 Pin Assignment

enter image description here

\$\endgroup\$
4
  • \$\begingroup\$ A very warm welcome to the site. Please can you edit your question and add a schematic of the oscillator and the MCP2510 pins. It helps a lot to see that rather than only have a description. Thanks and, again, welcome. \$\endgroup\$
    – TonyM
    Commented Dec 15, 2021 at 23:13
  • 1
    \$\begingroup\$ How did you probe it? 1x probe or 10x? \$\endgroup\$
    – Justme
    Commented Dec 15, 2021 at 23:54
  • \$\begingroup\$ I used a 1x probe on a 50MHz oscilloscope set to AC coupling. I was able to measure the output frequency from the 16MHz 32U4 clock. EDIT: reading up on the measurement technique I think I'm going to try measuring again with the 10x probe. \$\endgroup\$
    – Luke
    Commented Dec 16, 2021 at 0:02
  • 2
    \$\begingroup\$ Use the scope probe in x10 mode. The probe capacitance will stop correct operation. See electronics.stackexchange.com/questions/596360/… \$\endgroup\$ Commented Dec 16, 2021 at 0:08

1 Answer 1

1
\$\begingroup\$

After seeing JustMe and Kevin White's suggestions to use the 10x probe and reading up on what that means I tried measuring the clock signal again. I got a clean wave form with the 1M RS resistor from the MCP2510 clock, so it seems the probe was affecting the clocks operation after the addition of the RS resistor got the clock started.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.