5
\$\begingroup\$

I have an Arduino clone called the InduinoX. It works with my mother's laptops and I can program it, but in my other laptop it goes undetected. It's last uploaded program works when connected though.Both run Windows 7. Please help since. It worked before but stopped working with it abruptly.( In the IDE it asks me to go to tools and select serial port but it is grayed out)

\$\endgroup\$
  • \$\begingroup\$ When you connect it do you hear a sound from windows indicating something is connected? Have you looked at the device manager? \$\endgroup\$ – Gustavo Litovsky Mar 6 '13 at 16:13
  • \$\begingroup\$ I have an InduinoX, it's perhaps the best experimenter's board I have seen of the several different clones I have. Pretty much everything-proof too, see the video on their site about hosing the board with water while it is running! Also, everything is through-hole and easily repairable. \$\endgroup\$ – Anindo Ghosh Mar 6 '13 at 16:26
  • \$\begingroup\$ Sounds like a driver issue, which would be on-topic for superuser. \$\endgroup\$ – Turbo J Mar 6 '13 at 17:03
  • \$\begingroup\$ Find the DeviceManager from the Start menu and check if the device is found at all. From there you can check the driver status too and compare them between laptops. \$\endgroup\$ – jippie Mar 6 '13 at 17:04
  • \$\begingroup\$ it is possible that you aren't supplying enough voltage and/or current via USB to power the board. \$\endgroup\$ – Grady Player Mar 6 '13 at 20:10
4
\$\begingroup\$

Going by the description, the FTDI drivers on your other laptop have either gotten corrupted, been replaced by an invalid version, or are blocked due to lack of digital signature. Clearly, since the InduinoX still works as expected on one laptop, the problem isn't in the board.

Steps to diagnose / resolve:

  • Disconnect all Arduino boards from the other laptop, then manually remove any FTDI drivers that may be installed (they won't be active so won't show up in device manager). You may need to use the CDM uninstaller (download from FDTI site).
  • Download and install the latest FDTI drivers from the FTDI web site, by running the setup executable. Ensure you download the appropriate version of the drivers, Windows 7 32 bit or 64 bit as appropriate
  • Restart your computer just to be sure.
  • Connect the InduinoX back to the USB port, then see if the drivers configure themselves fine.
  • If the computer still doesn't show an additional COM port after this process, check for any devices in Windows Device Manager, with a red error flag. Right click and reinstall the relevant drivers, manually selecting the source folder as either the FTDI folder if you downloaded the ZIP file, or by unzipping the FTDI driver ZIP file that comes with the Arduino software distribution.
  • Once the new COM port shows up in device manager, fire up the Arduino IDE, and make sure you select the right COM port and the right board type ("Arduino Uno" works for my InduinoX board)

If it still doesn't work, you may need to reflash the bootloader on the board, but that is a very unlikely solution.


Post-script: Also see the InduinoX installation page.

\$\endgroup\$
  • \$\begingroup\$ Thanks for the reply. In the device manager, I deleted the Serial Converter , and re-installed the Arduino drivers and it started working after one restart.You were right, because I got error 52, lack of digital signature. So thanks man! \$\endgroup\$ – NobleSiks Mar 9 '13 at 6:08
  • \$\begingroup\$ You're welcome. Please accept / upvote an answer if it solved the issue. \$\endgroup\$ – Anindo Ghosh Mar 9 '13 at 6:26
  • \$\begingroup\$ Nope. Didn't work -- still nothing in device manager (not even an unrecognized device). It's not the bootloader (it wasn't the bootloader last time this happened, and it still works with the old computer). So it's something else. Will try enabling unsigned drivers next. :-/ \$\endgroup\$ – BrainSlugs83 Jul 2 '15 at 4:47
  • \$\begingroup\$ I figured out my issue -- it totally wasn't driver or software related. It was something with the 16u2 acting up. I smacked it around for a little bit, and then it started working. I have no idea what the exact cause or solution was, but it's working now. \$\endgroup\$ – BrainSlugs83 Jul 3 '15 at 22:08

protected by Dave Tweed Feb 26 '17 at 12:43

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.