1
\$\begingroup\$

I'm experiencing an interesting issue with Eagle's polygon copper pour. As you can see below, the solid red is the copper pour area, while the dashed line is showing the complete polygon outline (I clicked on it to show it). I don't know if you can see, but the pour (the solid) actually has a bend to it that is somewhat noticible. It's not straight as it should be. This is the first time I've seen this. There isn't anything on any other layer that I know could be causing this. Does anyone know what could be causing this? Is this a bug in the software? I'm using Eagle 6.3.0.

[Edit] Interestingly enough, moving the outline specified by dimensions more to the left does remove the issue, although it makes the board larger.

Polygon Copper Pour

Polygon Copper Pour Settings

\$\endgroup\$
  • \$\begingroup\$ I would also suggest looking at your output gerbers with a separate viewer program (eg ViewMate) just to ensure that this is not an artifact of Eagle's rendering. \$\endgroup\$ – spearson Mar 11 '13 at 15:06
  • \$\begingroup\$ @spearson: it's not. The issue is seen in the gerbers as well. Else i'd be very worried about my gerbers generated by Eagle. \$\endgroup\$ – Gustavo Litovsky Mar 11 '13 at 15:37
1
\$\begingroup\$

In Eagle, the actual final boundaries of the pour are constrained by things in addition to the polygon itself, including the width of the line used to define the polygon and several of the DRC clearance settings. In this case, it sounds like your pour is keeping away from the edges of your board as defined by your dimension lines. You can reduce this clearance in the DRC settings, but I wouldn't recommend reducing it to zero, as this can cause problems in fabricating the board.

\$\endgroup\$
  • \$\begingroup\$ I'll take a look at the DRC settings, see if something there influences it. I can likely take it down to 0.127mm and that should work. \$\endgroup\$ – Gustavo Litovsky Mar 11 '13 at 15:02
  • 1
    \$\begingroup\$ The Copper-Dimension DRC rule is set to a very conservative number by default (40 mils). If moving the Dimension outline fixes your problem, then this is the rule you want to tweak. \$\endgroup\$ – W5VO Mar 11 '13 at 15:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.