0
\$\begingroup\$

I have a setup like this :

enter image description here

The Power supply is a BK Precision's 1672 model. I am trying to push 1A through the 1 Ohm/ 10W resistor. The supply is in CV mode (The current output is set to maximum), and although the Power supply can push up to 3A, I cannot push more than 0.22 A through the power resistor.

The voltage across the resistor does not drop more than 0.3V.

I am sure there is an explanation for this, what is it?

\$\endgroup\$
6
  • \$\begingroup\$ What voltage does the p/s display when it's delivering 0.22A? You could post the photo of you power supply indicators while it's doing its thing, which you're trying to explain. Is the the circular symbol in your diagram a current meter (in addition to the indicator on the p/s)? \$\endgroup\$ Mar 14 '13 at 3:21
  • \$\begingroup\$ What is the output voltage set to? Also can you measure the resistance of the resistor and the ammeter shown? (it's possible the resistor is damaged, or the ammeter has quite a high current shunt resistance) \$\endgroup\$
    – Oli Glaser
    Mar 14 '13 at 3:36
  • \$\begingroup\$ @ Nick, the circular symbol is a Ammeter, when it is delivering 0.22A, the Voltage reads 0.2V. \$\endgroup\$ Mar 14 '13 at 4:06
  • 1
    \$\begingroup\$ Crank up the voltage, dude. \$\endgroup\$ Mar 14 '13 at 4:44
  • \$\begingroup\$ I have cranked it up to highest possible setting, both Voltage and Current. Which is why I am confused. Of course I have tried cranking it up! \$\endgroup\$ Mar 14 '13 at 6:54
2
\$\begingroup\$

It sounds like perhaps your voltage is set to below 1.0V. By Ohm's law (V=IR), you only need 1 volt potential difference to create a current of 1 amp across a 1 ohm load. What is the voltage across the output terminals of the power supply?

As an aside, it is probably more appropriate to say "The power supply can supply up to 3A." Power supplies often have two modes: voltage source or current source. In the voltage source mode (more common, usually) you set the voltage you want and draw the current your circuit draws up to the limit that the power supply can supply you (3A in your case). The second (current source) mode is probably more appropriate for the "pushing" analogy, since in this mode, the current source sets the voltage across its output terminals to create the desired current, again up to a limit.

\$\endgroup\$
1
  • \$\begingroup\$ The way I understand it, in CV mode (constant voltage mode) which is what happens if I crank my power supply's current knob to maximum setting, the supply will push whatever current is needed (up to 3A)to keep a voltage difference of up to 0 - 32V. I have it set to maximum current, and therefore, the green light "CV" is always on. The problem is .I cannot go over 0.2V no matter how hard I try ( both with and without the ammeter, so ammeter is not the issue) \$\endgroup\$ Mar 14 '13 at 6:57
0
\$\begingroup\$

As angelatlarge indicates - you need to have enough voltage available to push the desired current through the load in CC mode.

On supply below -

Disconnect load.
Turn current set knob to slightly above minimum.(note 1).
Set voltage to say 5V.
Short output leads and set current to desired current - here = 1A.
De-short output leads.
Connect load
Q.E.D.

The voltage will drop to whatever is required to provide 1A. it will be 1V for the load + something or the meter + something for the leads.

If you still do not get 1A, short out the external meter - the supply will show the current.
If with 5V available you get 1A with no meter but < 1A with the external meter get a small club hammer and pulversise the external meter and buy a new one. I have seem multimeters which when set to their 200 mA range have 17 Ohms internal resistance. Very bad!


Note 1: You set the current to slightly above zero when setting volateg as SOME supplies will shut down in CC mode with I=0 if current knob is turned right down to zero.

enter image description here

Picture from ad above - also here

\$\endgroup\$
2
  • \$\begingroup\$ I will try this and see how it goes \$\endgroup\$ Mar 14 '13 at 7:06
  • \$\begingroup\$ @EnderWiggins It will work perfectly if you follow what it says perfectly. Check in via Ansible when you get it working. If I'm asleep (not usual) just leave a dream. \$\endgroup\$
    – Russell McMahon
    Mar 14 '13 at 7:54
0
\$\begingroup\$

Okay, you have you supply set to 0.2V, so by Ohm's law:

\$ \dfrac{V}{R} = I = \dfrac{0.2V}{1\Omega} = 0.2A \$

This is roughly what you are seeing. If you want 1A through the resistor, then the voltage across it needs to be 1V. Remember to allow for any resistance the ammeter has, some low quality ammeters may have quite a large current shunt resistance. For example if the ammeter has 2Ω series resistance (measure it with a multimeter), then you need to calculate for this. If you still used 1V, then you would get:

\$ \dfrac{1V}{1\Omega + 2\Omega} = 0.333A \$

For 3Ω, you need:

\$ I \cdot R = V = 1A \cdot 3\Omega = 3V \$

Double checking:

\$ \dfrac{3V}{3\Omega} = 1A \$

The above is using constant voltage mode. You can also use constant current mode as Russell describes, just follow his advice.

\$\endgroup\$
2
  • \$\begingroup\$ It is not the ammeter, I have tried it with and without the ammeter. I am thinking it has to do with the power supply. No matter how much I try (maxed out both current and voltage knobs), the voltage will not go over 0.2V in CV mode. Perhaps I have a faulty power supply! \$\endgroup\$ Mar 14 '13 at 7:04
  • \$\begingroup\$ If it won't go over 0.2V with no load, then it sounds like your supply is indeed faulty. Make sure you try and test it without a load, just leave the leads disconnected and try and set it for e.g. 5V. If it reads 5V on the display, then test with a multimeter and check if you get 5V - if you don't, it's faulty. Make absolutely sure it's not set to constant current mode. Let us know the result of testing without a load. \$\endgroup\$
    – Oli Glaser
    Mar 14 '13 at 7:13
0
\$\begingroup\$

Thanks for helping me out guys, it was the stupid faulty power supply. Everything worked fine when I used a different one. The problem was that it acts fine without a load, but for some reason cannot source current more than 0.23 A

@Russell I am glad I am not the only one here who found the Ender's Game a fascinating read :)

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.