26
\$\begingroup\$

Intro how it happened:

I had cleaned my laptop from dust and reapplied the thermal paste. After this i have reassembled the device than it did not turned on. Then i took it apart connected the fan and it worked even POWER led was lit. Skipping the part when i constantly reassembled the laptop then find out it's not working so i started to remove the cables from the motherboard ( keyboard, fingerprint scanner etc ... )

Now i am at the situation where it wont turn on at all. I can hear a clicking sound every 2-3 seconds. Here is where i would like to ask for your help.


Measurements on motherboard:

  1. Maybe the laptop adapter is wrong: I have connected my lab bench psu and it won't work with that as well.

  2. Clicking noise---> let me see what is the ingoing current looks like

MOBO powered from DCIN, it's connector. Series current, 100mV/A, 568mV corresponds to around 5.7A Series current

From bird-eye view the current form looks like the following:

[Series current bird-eye view2

  1. Maybe there is a shorted capacitor. I have checked a couple of points on the circuit. Mainly it's input stage but nothing i have found. Also thinking of a short the component which malfunctions might heat up. With my thermal camera i didn't find anything hotter then +40°C (voltage rails are present so the DC/DC converters are doing something)

Here is the input stage: input_stage

Here is where VIN goes,high side swtiching mosfets: high_side_switch_mosfets

Voltage injection: I started injecting 5V after the switching mosfets(PQ311,PQ312) with current limit to see if i found the short. There was no high current so

-I injected 18.5V to PJ301 (basically N2) and the MOBO's POWER LED was lit.

-Injected 18.5V on N1 and the power led was lit

Voltage injected on either N1 or N2 produces the following current waveform: voltage_onN1_or_onN2 When the led is blinking the current is at on the wave's top part(at the level of the menu text MATH(OFF)). When the current is at "cursor S" the led is OFF constantly. To me without thinking much about it it looks like the MOBO is working and managing itself.

-Injected 18.5V on VIN then MOBO is not working but shorting PQ311(source and drain together) "does the trick" and MOBO works.

I have replaced PQ311 as came to the conclusion i had no better idea at that point. Changing PQ311 has not solved the problem, i was feeling it won't but anyway proceeded with chaning. I tested components connected to VIN if they are shorted or something but not found any suspicious.


I put additional measurements i made on the circuitry that might help you:

Voltage injected on DCIN while measuring voltage on ACDET point during inrush current. (LED is not working) acdet_circuit voltage_acdet Bird-eye view acdet_bird_eye

Voltage injected on DCIN while measuring voltage on ACDRV point during inrush current. (LED is not working) ACDRV_circuit ACDRV_voltage

Voltage injected on N1. LED is working enter image description here During this i measured 25.4V on ACDRV with a DMM


At this point i would like to ask you for your thoughts and help.


Follow-up:

2022-03-15:I was checking the capacitors and power rails if there is a short to ground. I was doing as Ilya suggested, not looking at the schematic. I find only low impedances on the rails which connect to the CPU or GPU, around 10-15 Ohms. Also checked every voltage on the following schematic and they were all present voltage_rails While doing this the board came alive.

So thinking a bit and left with no other option i begin to clean the board once again. Clean the applied heat paste as well ,from CPU and GPU. I looked it up before and this thermal paste is a non-conductive type so in theory it can't cause short right(thermal paste link)?! Also saw some really small amount at two points on the pcb where there was solder mask underneath it. I cleaned these as well(the thermal paste got transfered to these points during the analysis measurements). I am giving this cleaning a 50-50 chance as now i have no better option. I will assemble together the PC when i will have time, altough i have connected the FAN and it worked. I switched on and off of the supply to see if it will power up. Done it more than 15 times and it have not had any problem.

2022-05-10:Cleaning did not solve the issue. Altough i have some new information.

  1. I have started going brute force. Desoldered all the tantalum capacitors and electrolytic if they might cause the sort. This has not solved the issue.
  2. Tested power rails by injecting 1.2V to see if there is a short. This has not solved the issue.
  3. I have replaced BQ24780SRUYR and the 10mOhm shunt. This has not solved the issue.

Now i have found some interesting stuff. If i put a wire like so:

going around mosfets device starts up, LED lights up. Then while the device is still powered and working I remove the wire and the device kept on going. To me this means there is some transient during startup which causes the problem and triggers some protection.

\$\endgroup\$
4
  • 10
    \$\begingroup\$ Wow... It's spectacularly rare for such a detailed repair question to get posted here. Wow. Would give you multiple +1's if I could! \$\endgroup\$
    – brhans
    Mar 3 at 1:50
  • \$\begingroup\$ Have you checked the condition of PR301? At 0.01R it'll be difficult to test, but your waveform showing ACDRV & series current makes me wonder if the BQ24780 thinks it's detecting an over-current condition (measuring the voltage across PR301) and trying to shut down. You could try bridging over PR301 pins 2 & 3 or PC305 with a short jumper wire to see if that makes the BQ IC happy. \$\endgroup\$
    – brhans
    Mar 3 at 1:54
  • \$\begingroup\$ @brhans Thank you for your kind words. : ) I tried to document as much so it helps other understand the problem. I am happy you liked it. It takes time but definitely worth it. \$\endgroup\$ Mar 15 at 20:36
  • \$\begingroup\$ @brhans With the PR301 shunt resistor i was thinking the same. If it degrades over time it's resistance would rise (probably?) then the BQ24780 would detect a false OC event then shutdown the whole thing. I have edited the post on 2022-03-15 and now the MOBO works, currently. I would cross out a worn out shunt resistor for this reason. \$\endgroup\$ Mar 15 at 20:43

1 Answer 1

16
\$\begingroup\$

Repair tech here! Solid analysis. I advise against injecting 18V, because your main power bus of the board is probably 12V or so, and there is a chance that the switching MOSFET that converts it to 12V is burnt through, so your main power bus voltage becomes 18V instead of 12V. This correlates with the laptop turning on, because all the other voltage converters can often survive short-term overvoltage, I've seen it myself.

You never mentioned the model of your laptop and what kind of power draw one could expect (at least how many watts your charger is, it gives some estimate on what to expect - bear in mind it's battery charging + board draw).

PQ311/312 are not switching mosfets, they are charger isolation mosfets (and there is no inductor, a dead giveaway). Notice they're back to back, blocking current in both directions. If there is lack of info, it's actually an acceptable (but not perfect) solution to just bypass them with thick enough wire. But don't do that just yet, because of possible burn-through of 18V to 12V. If that's the case, it's not an acceptable solution.

Power cycling usually means there is most likely a short on one of the secondary power lines (or current sensing circuit, but that comes only with water damage), at least it appears at some point when lines turn on, so the whole thing resets. Look for coils/inductors on the board and beep them to the ground. Without looking at the schematic. Just look around the board and probe stuff. CPU/GPU power lines have little impedance, so they will always beep (they're beefy and are right near CPU/GPU), but you can measure voltage on them. If anything other than CPU/GPU power beeps, it's worth measuring voltage there.

For now, follow the power line after the isolation MOSFETs, find the main power buck converter and check if it's doing OK, including its switching MOSFETs (beep drain to source and back). Check the voltage on the main power line when you try to turn it on, as well as on 5V and 3.3V supplies, which you should be able to find in schematic.

EDIT as to where this supposed short disappears when you bypass the isolation - some voltage converters may not receive signal to start switching when you bypass isolation, this is highly individual for every laptop. If there is a burn-through of the high side switching mosfet, the lower side mosfet simply never turns on and the upper one passes full voltage through permanently, so the thing turns on as if there is no short. The short happens when under normal operation without bypass, the converter starts switching and the lower side switching mosfet turns on, while the upper one is burnt through and conducts as well.

This is of course only educated guess and my would-be first steps.

\$\endgroup\$
1
  • 2
    \$\begingroup\$ Thank you for your comment! Also thank you for pointing out that those MOSFETs are not switching mosfet but working as isolators. This is why i should get some sleep before trying to write a long post : ). Also one can see they are not working in switching-mode just looking at ACDRV's constant value. I have done some measurements based on your hints. Added the results to the post so if you are interested check it out. : ) Also thank you for your long comment on this topic, it helped! \$\endgroup\$ Mar 15 at 20:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.