1
\$\begingroup\$

A question about this circuit was posted and immediately deleted.

It is a simple circuit, but I found this when I simulated it.

First, DC analysis, nothing strange:

enter image description here

Then analyzing more: parameters DC Analysis, Globals Settings : Standard. microcap12

enter image description here

enter image description here

One can see that there is a Vc "negative" voltage between 1 < V1 < 7 V. I am amazed by this result.

Ok, the BJT "model" can contain some "generator", but is it really possible that Vc can become "negative" in this simple circuit?

EDIT: for comparison, BC547 and BC847 (this one is ok) parameters used

From file D:__Utiles\mc12cd\library\MSBJT.LBR NPN Amplifer transistors
.MODEL BC547 NPN (BF=437.641 BR=2.55977 CJC=6.40421p CJE=19.7395p IKF=544.354m IKR=985.432 IS=7.88857f ISC=7.52015p ISE=.0000161327f ITF=9.88981m MJC=316.254m MJE=312.92m NE=1.24119 NF=968.124m RE=1.23191 TF=374.789p TR=10n VAF=100 VJC=700m VJE=770.586m VTF=10 XTF=499.98m)

From file D:__Utiles\mc12cd\library\MSBJT.LBR NPN Amplifer transistors From file D:__Utiles\mc12cd\library\PH_BJT.LIB
.MODEL BC847 NPN (BF=324.4 BR=8.29 CJC=3.347E-12 CJE=1.244E-11 FC=0.979 IKF=0.109 IKR=0.09 IRB=5E-06 IS=1.822E-14 ISC=9.982E-12 ISE=2.894E-16 ITF=0.3131 MJC=0.391 MJE=0.3656 MJS=0.333 NC=1.763 NE=1.4 NF=0.9932 NR=0.9931 RB=10 RBM=5 RC=0.7014 RE=0.649 TF=4.908E-10 TR=9E-08 VAF=82 VAR=17.9 VJC=0.5463 VJE=0.7579 VJS=0.75 VTF=2.927 XCJC=0.6193 XTF=9.51)

\$\endgroup\$
9
  • \$\begingroup\$ What step size did you use? \$\endgroup\$
    – Andy aka
    Mar 10 at 20:05
  • 1
    \$\begingroup\$ @Antonio51: It is probably related to the effect I asked about in this question last year. \$\endgroup\$
    – JRE
    Mar 10 at 20:22
  • 1
    \$\begingroup\$ Try to use BC847C insted. \$\endgroup\$
    – G36
    Mar 10 at 22:41
  • 2
    \$\begingroup\$ @Antonio51 LTspice shows a similar shape but it does NOT go negative. However, there is an effect that can take place as the BE junction emits light and where that light (which cannot normally be seen in a packaged BJT) does cause photo-generated charges and these can cause the collector to go negative. Just not in this circumstance, so far as I'm aware. It is most noticeable with the collector open and very very lightly loaded by the instrument measuring the voltage there. I doubt your simulator handles this case. \$\endgroup\$
    – jonk
    Mar 11 at 5:19
  • 2
    \$\begingroup\$ @Antonio51 I also don't think it is taken into account by the simulator. \$\endgroup\$
    – jonk
    Mar 11 at 8:41

2 Answers 2

1
\$\begingroup\$

After some search within parameters, I found that the "BR" parameter has something to do with this phenomenon. However, I found that some new parameters were added to the BJT BC847C.
To illustrate, I "created" some BJT_bis, changing this BR parameter.

enter image description here

And the results with changing only this parameter (see Vc1 and Vc3).

enter image description here

\$\endgroup\$
3
  • 1
    \$\begingroup\$ Here's what I got just changing BR alone. Note that other parameters were likely different than yours. But do take note that at no time does the collector dive below 0 V in LTspice simulation. It may be that BR interacts with some other parameter where LTspice might replicate your results. But I can't tell, as yet, and it certainly isn't only BR by itself. \$\endgroup\$
    – jonk
    Mar 11 at 17:11
  • \$\begingroup\$ << it certainly isn't only BR by itself >>, yes, I agree. I changed quasi all parameters of BJT I had in the simulator, (one by one, at one time only) and it was the most significant. Sure, it is a "little" problem with the "model" used by simulators. I am searching for a "note" where all these parameters are "evaluated". Anyway, thanks for you simulation. :-) \$\endgroup\$
    – Antonio51
    Mar 11 at 18:47
  • \$\begingroup\$ I tester BR of the BJTs I have on my bench at 1mA (BC548B and BC337-25). Most of them are from Philips and ST. And for BC548B the BR was around 8 and for BC337-20 around 38. \$\endgroup\$
    – G36
    Mar 12 at 15:36
0
\$\begingroup\$

Without knowing what your simulator program is and the specific simulation parameters, models and SPICE netlist you use, it is difficult to replicate.

Anyway, that voltage goes negative for some millivolts, so it could either be some simulation artifact or some "real effect" due to parasitic inductance/capacitance of the BJT model.

\$\endgroup\$
1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.