0
\$\begingroup\$

I'm trying to make an LED strip work, with these parts:

  • A WS2812B LED strip (60 LEDs/m), 5V
  • An Alitov 5V 15A power supply
  • An Arduino Nano

My issue is that the strip isn't getting the 5v it requires. The arduino is just running simple code to show all white LEDs. See below pictures for my wiring: enter image description here

enter image description here

As you can see, it's measuring around 1 volt across the 5v and GND terminals at the start of the strip. This seems... very wrong. When I rotate the barrel plug adapter, the LEDs flicker red a bit, and I've measured up to 1.6V in brief moments. I don't know if it's my barrel adapter, or the power supply, or even the way I'm inserting the wires into the barrel adapter? The weird part is this used to (mostly) work fine.

edit: as per comments, I measured the voltage on the barrel adapter and it's 5.19V so that seems fine. However, when the wires are inserted, it drops to ~1V. Here's how I'm putting the wires into the adapter:

enter image description here

I fold them back so there's no exposed wire hanging out of the adapter. I screw down the adapter's screws and it's plenty tight; the wires won't come out, but still not enough voltage. I've also tried un-folding the wires and sticking them in straight, same result.

\$\endgroup\$
15
  • 1
    \$\begingroup\$ Seems like your red wire is disconnected from your power supply. Your 1V probably comes from the USB leaking through some parts or the communication bus. \$\endgroup\$
    – Damien
    Commented Mar 20, 2022 at 19:14
  • 2
    \$\begingroup\$ You have a multimeter. Use it to pin-point if it is the barrel adapter, or power supply, or the way you are inserting wires to the adapter. \$\endgroup\$
    – Justme
    Commented Mar 20, 2022 at 19:15
  • \$\begingroup\$ @Damien the red wire is just stripped back to reveal about 1cm of bare wire, and the adapter is only a few mm deep. \$\endgroup\$ Commented Mar 20, 2022 at 19:24
  • \$\begingroup\$ @Justme I tried that, and it looks like the adapter's terminals have 5.19V across them, so it's probably the way I'm inserting the wires... what's the right way to do it? \$\endgroup\$ Commented Mar 20, 2022 at 19:24
  • \$\begingroup\$ You probably put the black wire to terminal with isolation. The bare copper should be seen out of terminal. \$\endgroup\$
    – user263983
    Commented Mar 20, 2022 at 19:29

1 Answer 1

1
\$\begingroup\$

You either have a bad connection, high resistance, or a short/faulty component. Or a bad power supply.

Replace the wires and or try with a different part. That's essentially the only troubleshooting. Longer explanation, check solder joints, make sure the wire is the right guage for the adapter or it won't connect/squish down correctly.

\$\endgroup\$
7
  • \$\begingroup\$ Is it normal for the voltage across the barrel adapter terminals to drop once the wires are connected? That's the biggest 'sign' I see; when it's not connected to my other wires, I see 5.2V, but once it is hooked up, it drops to around 1V. I just don't know enough about electronics to know why... \$\endgroup\$ Commented Mar 20, 2022 at 23:22
  • \$\begingroup\$ If the adapters terminals/power supply drops down to 1V when you connect a load, that means your load is too much for the supply. Some supplies will droop down others will shut off based on over current protection. Maybe your multimeter is averaging out the reading and your supply is rapidly turning off. So your supply is bad or you have a short somewhere causing a large drop. Double check your solder joints on the led strip. \$\endgroup\$
    – Passerby
    Commented Mar 20, 2022 at 23:27
  • \$\begingroup\$ The place where the wires join the strip is covered up in some black heat shrink, I think... I can't see what's underneath. I've not done any soldering myself (I don't have an iron) so I'd hope the factory soldering is fine... \$\endgroup\$ Commented Mar 20, 2022 at 23:29
  • \$\begingroup\$ I've tried using a new Arduino Uno, no difference. The only thing that makes any light at all show up is semi-randomly rotating the barrel adapter on the barrel plug, or taking the adapter off slightly and putting it back on. But even then it's not full brightness, it's just lighting up slightly red momentarily. To me that implies a bad barrel connection, but if that were the case, why would it measure 5.2V without wires... \$\endgroup\$ Commented Mar 21, 2022 at 5:03
  • \$\begingroup\$ High resistance of the connection. Are you sure you have the right size barrel connector? 5mm out 2.5mm in or 2.1mm in? If you use a different adapter? \$\endgroup\$
    – Passerby
    Commented Mar 21, 2022 at 5:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.