1
\$\begingroup\$

I am currently using a NUCLEO-WL55JC board. However, I could not initialize the logic analyzer because of the error "Trace: No Synchronization". I am programming it as single-core (Cortex M4 mode).

The watch tab works well, but the analyzer window seems to be not working. And, I have an error at the bottom showing "Trace: No Synchronization". I set the core frequency (4 MHz) as the same as the board's frequency (4 MHz).

What is your advice? By the way, I have a physical logic analyzer device at home and can use it instead of the virtual one if possible. Please let me know.

What I tried so far:

  • Enabled DEBUG in CubeMx as "SerialWire" and "Trace Asynchronous Sw"
  • Set on Solder Bridge 8 on the board (the manual advises it to enable SWO)
  • Set different core frequency and keil debug frequency
  • Using an external ST-LINK device

enter image description here

\$\endgroup\$

1 Answer 1

1
\$\begingroup\$

Solved! Inattention. "Solder Bridge 8" is labeled as "SB8", but I thought it was "Jumper 8".

"SB8" is located at the side of the CPU, I just soldered it. The trace works now!

\$\endgroup\$
1
  • \$\begingroup\$ Faruk UNAL - Hi, Thanks for coming back with the answer to your question. In order to mark the topic as solved, please "accept" your answer (click the "tick mark" next to your answer, to turn it green). Then it is shown as having an accepted answer in various lists here, and we don't get nagged for it being a question with an unaccepted answer. Since you must wait 48 hours after you asked the question before you can accept your own answer, you can accept it any time after 21:23 UTC on 23 April. Thanks. \$\endgroup\$
    – SamGibson
    Apr 22, 2022 at 17:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.