2
\$\begingroup\$

I am currently running into a problem in KiCad where the ground plane won't connect to some pads.

KiCad even tells me to connect them but doesn't seem to make the connection automatically.

enter image description here

enter image description here

\$\endgroup\$
4
  • \$\begingroup\$ What are the settings on the zone and the pads? \$\endgroup\$
    – Hearth
    Apr 23, 2022 at 16:09
  • \$\begingroup\$ they need the same signal definition just any other wire to pad. \$\endgroup\$
    – old_timer
    Apr 23, 2022 at 16:15
  • \$\begingroup\$ and/or when you run the rules check part of that is it computes the ground plane connections... \$\endgroup\$
    – old_timer
    Apr 23, 2022 at 16:15
  • \$\begingroup\$ Things to check for: thermals (for the ground polygon, for the pads); any keepout zone in pcb or footprint? Overlapping pads in the footprint? \$\endgroup\$
    – DamienD
    Apr 23, 2022 at 16:16

1 Answer 1

2
\$\begingroup\$

I just checked the settings of the plane and realized that pad connections were turned off. I placed another pad and KiCad turned connections on automatically. It was just a dumb mistake on my part; I thought they were enabled by default.

Thanks for the comments as they made me double-check the settings.

\$\endgroup\$
2
  • \$\begingroup\$ what settings have you changed? where they are? \$\endgroup\$ Mar 4, 2023 at 15:23
  • \$\begingroup\$ If you look at the copper zone properties (click on the plane and press e) you will see a Pad Connections: drop down under Electrical Properties. You can pick Solid, Thermals, None, etc \$\endgroup\$
    – skot9000
    Jun 8, 2023 at 0:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.