0
\$\begingroup\$

I have a servo motor with 4 brushes on its commutator. The motor is connected to a controller that enables the user to control the speed and at the same time it has an analog RPM meter which most probably measures the speed of the motor through the two additional brushes on its commutator.

After doing normal maintenance for the motor (checking the brushes, and greasing the bearings), the RPM meter became very inaccurate like reading about half of what the speed should be. I have tried and tried, but matter what I do, I can't calibrate it back to how it was.

I was wondering what is the mechanism for this speed measurement to see if I can find another way to measure the speed continuously through these brushes.

Here's a motor like the one I have:

enter image description here

\$\endgroup\$

1 Answer 1

1
\$\begingroup\$

After some searching i figured out that this motor is combined with tachogenerator and it's output is 14v/1000rpm. Most probable causes at my opinion may be: 

  • motor and tach terminals were accidentally swapped
  • tach brushes were swapped or flipped which causes bad contact to commutator and thus big voltage drop. Typically brushes should fit better after some minutes of spinning.
  • lube or dirt marks on tach commutator or brushes, if exist, should be removed with solvent
  • previous causes may be present in main commutator, resulting in low real speed.
  • theoretically, main and tach brushes can be made of different materials and, if swapped, work not as good as before.
\$\endgroup\$
1
  • \$\begingroup\$ what bugs me is that the motor spins very good now and it can reach the top speed 3000+ with no issues now. I had to give it a push before to make it spin.. and I am pretty sure the 3 first points you mentioned are all good.. but gonna give them another shot and see.. \$\endgroup\$
    – Shamooooot
    May 13 at 4:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.