2
\$\begingroup\$

I'd like to use Work Sans for text on my PCB design, however Altium is showing some artifacts in the font that appear as white spaces within characters. This only happens on some fonts but not others. This issue shows up in the CAMTastic gerber viewer as well, it is not limited to the layout view.

I have reinstalled Work Sans.ttf fonts a few times. What's more puzzling is that I was able to use Work Sans in previous designs without issue, this problem only seemed to happen after reinstalling my system recently.

Please see the following screenshot. Note the characters k, a, t, g, appear correctly in a different font, but features gaps and other errors in Work Sans.

Screenshot with three different strings

\$\endgroup\$
3
  • \$\begingroup\$ Is the option to embed TrueType fonts in PCB documents by chance enabled/disabled differently from before? (altium.com/documentation/altium-designer/…) \$\endgroup\$
    – JYelton
    May 16 at 15:48
  • \$\begingroup\$ @JYelton I just checked the preferences dialog. It looks like it matches the altium doc page, with the checkbox checked and substitution font set to default Aerial. Unfortunately disabling the option doesn't seem to fix the issue either \$\endgroup\$
    – crossroad
    May 17 at 16:05
  • \$\begingroup\$ Unfortunately I don't think a good answer can be furnished here. Between updates to your OS and Altium, and the finicky nature of TrueType fonts, I would expect you'll need to contact Altium support or ask on the Altium forum. \$\endgroup\$
    – JYelton
    May 17 at 16:16

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.