0
\$\begingroup\$

EDIT: This problem is solved. To anyone reading this after the fact, let it be a lesson in making sure that your equipment actually works as intended.

I'm a physics undergrad, not an engineer, so please forgive me if the solution is obvious.

I have a DC shunt motor that I'm trying to control for the lab I'm working with. It is meant to turn a shaft that raises a platform up and down in a Bridgman furnace. To do this, there is an overall scheme involving an Arduino and some isolators, but the part of the circuit in question is the MOSFET's that I'm using.

The motor itself is meant for low speed, high precision turning. It requires a 120V DC input, which is most of the problem. To speed control this motor, I'm trying to amplify a PWM signal from my Arduino by using two MOSFET's as switches on the motor's two internal circuits, the field and the armature, both of which being connected to a power supply. The MOSFET's have already worked for me before, having tested them with basic LED setups. Now I'm trying to stitch it all together, connecting the MOSFET's with the motor and everything else in the project.

MOSFET Datasheet. There's a few in there. Mine are the RFM10N12L.

The issue arises when I actually turn the motor on. Even at a low speed, the MOSFET connected to the field circuit gets scorching hot (to the point where it melted my breadboard and burned my finger pretty nastily) while the other one runs fine (the motor is successfully turning while this happens). I don't know why this is happening, and I'm not even sure that it's problematic because, from what I've gathered from the Internet, sometimes MOSFET's just get hot and require heat sinks. I'm here looking for reassurance on that point because the other MOSFET isn't getting hot. I also know that it's not an issue with the MOSFET's themselves, since switching which circuit is connected to which MOSFET changes which MOSFET gets hot.

It's also important to note that this behavior is still there when the gate is held at the steady on voltage (100% duty cycle), and the voltage (6 V) is enough to fully turn on the FET. Thus, RoyC's answer about it being caused by the FET being in linear mode for too long is not the issue. Something else is going on.

My hypothesis for the difference in behavior is based on the fact that the armature circuit and field circuit are two different kinds of circuits. The field circuit effectively acts like a capacitor (while the armature doesn't), and from what I understand, MOSFET's get hot in situations where they are in series with capacitors.

I have no idea if I'm in the right ballpark, though, hence why I'm here. Any input on this situation would be appreciated.

Here's a diagram of the situation:

enter image description here

Wires of different colors that pass through each other are not connected.

\$\endgroup\$
8
  • \$\begingroup\$ Why are you PWMing the field winding? What is its DC resistance? Please put link to MOSFET datasheet in question. \$\endgroup\$ Commented Jun 22, 2022 at 23:35
  • \$\begingroup\$ Please specify the chosen MOSFET types, the PWM frequency and the MOSFET driving circuit. \$\endgroup\$
    – Jens
    Commented Jun 23, 2022 at 0:46
  • \$\begingroup\$ The purpose of PWMing the field winding is to be able to turn the motor off instead of turning off the power supply manually. The point of this project is just to be able to control the furnace remotely without actually being in the lab. Not sure about its DC resistance. As for the MOSFET's datasheet, that's now an edit in the question, but the link is also here: rocelec.widen.net/view/pdf/lfq5hnmblh/…. There's a few in there. Mine are the RFM10N12L. The PWM frequency is 490 Hz, as is the case for Arduino PWM, unless I wanted to do 980 Hz, which is another option. \$\endgroup\$ Commented Jun 23, 2022 at 2:12
  • \$\begingroup\$ Is it possible, that armature and field connections are interchanged? Armature would draw excessive current without field, but field not without armature. DC resistance can be used to check this. \$\endgroup\$
    – Jens
    Commented Jun 23, 2022 at 2:44
  • \$\begingroup\$ Unfortunately, no. I actually wasn't sure of that as I was writing this question, but then it occurred to me that I could just take apart the motor and check. I did and found that the connections are correct. I do have an alternative guess, though, that being that the motor is old and broken. A while back, I was trying to get it to move full speed just on its own, without the MOSFET craziness, and it moved fine, but started smoking after awhile. It just now occurred to me that those things may not be unrelated. I'll be checking tomorrow, and if that's the case, I'll retract the question. \$\endgroup\$ Commented Jun 23, 2022 at 4:12

1 Answer 1

1
\$\begingroup\$

I figured it out. The motor I was trying to use was just broken. I connected it to a different motor, and the setup works just fine. Thanks to the people that tried to help, and sorry for the fake problem.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.