0
\$\begingroup\$

I am trying to convert from DipTrace, where there is a built-in mounting hole feature in their PCB layout, which auto-populates a keep-out region around the hole. The keep-out region is where I don't want copper to be placed. It seems like in KiCad, mounting holes are generated as an actual component footprint, either from the standard mounting hole footprints in KiCad's library or by creating your own custom footprint. You can then right click on the component and set the clearance around the hole to define the keep-out region.

The problem I have is that there is seemingly no way to permanently display the clearance around the hole. The clearance does appear when I click on the individual holes, but once I click away, it disappears.

It seems like I could use KiCad's built-in rule area/keep-out and place a circle around the hole. Then, I could group the keep-out and hole together, so they move around together and essentially act as one component. But it seems like you can only create polygons with the KiCad's built-in rule area/keep-out. Is there no way to create circles?

I could also define a custom layer to show the clearance around the mounting hole. But I actually have both circle and oval mounting holes. It seems you can create oval mounting holes with no problem, but you cannot create oval shapes when drawing on a layer (besides doing some custom manipulations with arcs and straight lines, which is a nightmare to get the angles and overall shape correct).

The picture below is for reference. The left two mounting holes show what I want to achieve. The right two mounting holes, on the other hand, do not have any keep-out markings.

Are there some features that I am missing here or does KiCad lack the functionality to do this?

enter image description here

\$\endgroup\$

1 Answer 1

0
\$\begingroup\$

In KiCad version 6.x, you need to ensure that the Pad Clearance option is checked

Board Editor Preferences

\$\endgroup\$
1
  • \$\begingroup\$ Thank you. Sorry for the delayed response. I already had this option checked in my settings. When I uncheck this option, I do not see any pad clearances at all when I click on the pad. When I check it again, I only see the pad clearance when I click on the individual pads and have them selected. Is there a way to always show the clearances when the pads are not actively selected? I also have the "show always" option checked. Is this some bug with my version of KiCad? I am using version 6.0. \$\endgroup\$
    – John Allen
    Jul 13 at 13:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.