I am creating a new database library for Altium using Microsoft Access 2016.

I've only ever previously used database libraries using Excel, integrated libraries or had someone else in a company manage them.

I have a Access database set up with a table for each category, at the moment I am concentrating on getting on table working with Altium, then I'll copy the process for the remaining tables, firstly I am working on Capacitors.

In the schematic I only want the designator and value showing.

However when I insert a component the designID from the schematic symbol library shows as below:

How it appears on a schematic

Here is my dblib setup: enter image description here

My database table: enter image description here

Table design:

enter image description here

Schematic Symbol Properties: enter image description here

How can I stop the designID (in this case 'NonPolCapacitor') from showing on all components on the schematic?


1 Answer 1


The Design Item ID doesn't show on schematic symbols. But often the Comment field does, and is usually a duplicate of the Design Item ID initially.

Turn off the visibility (the eye icon) for Comment, or set the Comment field to be blank.

Altium Schematic Symbol Properties

Hide (or show) fields that you want in the library, and later when adding them to a schematic, they will use the visibility set when you saved the symbol.

If you already have an entire schematic with some property you want to hide, you can follow these steps:

  1. Select all of the components with the property in question. (Shift+F on a component to open the find similar objects dialog, then select attributes which will filter for the desired items).

  2. With all objects selected, change the visibility for the property. This will affect all selected items.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.