0
\$\begingroup\$

Here is my whole diagram. There is no output while also clock is ticking...

I think there is a problem with the counter, but I can't figure it out.

I use rising-edge flipflops.

whole thing while clock= 0

whole thing while clock= 1

counter= 0

counter= 1

decoder= 0/1

\$\endgroup\$
13
  • \$\begingroup\$ I hope you will add your schematic soon. \$\endgroup\$ Jul 27 at 19:29
  • 2
    \$\begingroup\$ Since this looks like homework we will expect you to show us that you have made a substantial effort to solve this yourself. Show us all of your work: truth tables, state tables, etc. Describe exactly what "doesn't work" means. Then you can ask a specific question. \$\endgroup\$ Jul 27 at 20:06
  • \$\begingroup\$ You proably need a power-on reset to set the flip-flops to a known initial state. \$\endgroup\$ Jul 27 at 20:12
  • 1
    \$\begingroup\$ I added clock in place but no outputs. - Do you see the clock changing? \$\endgroup\$
    – Eugene Sh.
    Jul 27 at 20:15
  • \$\begingroup\$ Also your NAND output connection doesn't look good. Delete the line and reconnect. \$\endgroup\$
    – Eugene Sh.
    Jul 27 at 20:17

1 Answer 1

0
\$\begingroup\$

If those are positive edge triggered flip-flops then you need to come off the Q-bar outputs into the next clock inputs for an up counter. Come off the Q outputs as shown in your diagram if the flip-flops are negative edge triggered. If the flip-flops shown are positive edge triggered then the counter will count down from 0 direct to 15 and immediately reset back to 0.

\$\endgroup\$
1
  • \$\begingroup\$ ya, I got that. Now I solved... Thank you \$\endgroup\$
    – Aryan JR
    Jul 28 at 8:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.