0
\$\begingroup\$

I am having a situation with my ESP32S Node MCU that I can't figure out.

I uploaded a sketch to my MCU that will blink the blue LED connected to GPIO 2 every x number of seconds. Here is the sketch

/*
 * https://circuits4you.com
 * ESP32 LED Blink Example
 * Board ESP23 DEVKIT V1
 * 
 * ON Board LED GPIO 2
 */

#define LED 2

void setup() {
  // Set pin mode
  pinMode(LED,OUTPUT);
}

void loop() {
  delay(500);
  digitalWrite(LED,HIGH);
  delay(500);
  digitalWrite(LED,LOW);
}

When I power the board through the USB interface, the sketch runs correctly and I can see the blue LED blinking.

However, when I power the board through the Vin and GND pins, using a 12V LiPo battery connected through a buck regulator which switches the voltage down to 5V, the blue LED doesn't blink at all. The red power LED turns on fine and I get 4.24V across Vin and GND when testing with a multimeter.

Does the blue LED require power through USB to work? Or am I not supplying enough power to the board?

What is the standard sketch to run on an ESP32 to check if the PSU is functioning correctly?

\$\endgroup\$
5
  • 1
    \$\begingroup\$ Which exact board are you using, which exact regulator you are using, and how exactly you are connecting them? For example, have you checked if the regulator can output as much current the MCU board needs? \$\endgroup\$
    – Justme
    Sep 8 at 8:09
  • \$\begingroup\$ The voltage from Vin generally gets regulated to 3.3V. Can you check the voltage at the 3.3V pin in your board with a multimeter ? \$\endgroup\$
    – Rahmany
    Sep 8 at 8:43
  • \$\begingroup\$ Don't work Even after a "reset"? \$\endgroup\$
    – Antonio51
    Sep 8 at 8:55
  • \$\begingroup\$ @Justme - The board I'm using is the ESP32S Node MCU V1.1 with 38 GPIO's. The exact regulator I am using is this one - robu.in/product/… with an output of 5V, 2A. \$\endgroup\$ Sep 8 at 10:45
  • \$\begingroup\$ @random_coder_101 You already solved the problem of wrong connections 1 hour ago, adding the regulator type is not necessary any more. \$\endgroup\$
    – Justme
    Sep 8 at 11:00

1 Answer 1

0
\$\begingroup\$

Okay, the reason turned out to be really silly.

When looking at the pin names on the back of the board, I misread the CND pin (which is actually supposed to read CMD, I believe) as GND and tried to supply power via the two adjacent pins.

When supplying power via the 5V pin and GND pin, everything works fine and the sketch runs as expected.

Here's a blog post that goes into more detail about it.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.