0
\$\begingroup\$

I am working with a Beaglebone Black and a 4D Systems gen4-4DCAPE-50T resistive touchscreen. The screen display works, however, I do not receive any touch events.

I don't really have an option of flashing an image that we know works as this is part of a larger project that has been developed for years, so I boot it from an image of the Beagle that I have on an SD card.

I know that this should work as it has worked before but I broke the system and had to reboot from the SD card image that we have. When doing this I don't get touch events. As this is the resistive touchscreen I am using the ar1021 driver and I can confirm that it is loaded as it is in the list of lsmod.

In dmesg I get things like input: ar1021 I2C Touchscreen as /devices/platform/ocp/4802a000.i2c/i2c-1/1-004d/input/input0 so it seems to bind correctly on i2c-1. However, when running i2cdetect on 1 I get nothing:

enter image description here

When running i2cdetect on 2 I get:

enter image description here

I can confirm this is the EEPROM of my touchscreen. Should the AR1021 chip and the EEPROM of the touchscreen be on different I2C busses? My boot folder has the contents of:

enter image description here

So I am assuming the I2C-1 is set up correctly according to bbb-gen4-4dcape50t.dtb.

I have tried things like cat /dev/input/event0, evtest, and many other cat-s, but nothing responds to a touch event.

Any suggestions would be greatly appreciated as I can't even see what could be wrong other than nothing being returned by sudo i2cdetect -y 1.

New contributor
Jordan Marshall is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
\$\endgroup\$

0

Your Answer

Jordan Marshall is a new contributor. Be nice, and check out our Code of Conduct.

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.